Skip Navigation

[Resuelto] PROBLEMA CON FILTROS

Este es el foro de soporte técnico para Toolset: un paquete de plugines para el desarrollo de sitios WordPress sin escribir PHP.

Cualquier persona puede leerlo, pero solo los clientes de Toolset pueden publicar en este foro. El soporte de Toolset atiende 6 días a la semana, 19 horas por día.

This topic contains 15 respuestas, has 2 mensajes.

Last updated by vincenzoD-2 hace 2 meses, 3 semanas.

Assigned support staff: Jamal.

Autor
Mensajes
#2119831
Captura de pantalla 2021-07-20 a las 11.40.38.png

Hola Nigel!
Después de la última actualización tengo un problema con los filtro. Prácticamente sin poner ningún filtro se seleccionan algunos automáticamente y además el filtro "busqueda de entrada" no me deja poner ninguna palabra.

¿Me puedes ayudar con esto?

Muchas Gracias

#2119905

Jamal
Supporter

Languages: Inglés (English ) Francés (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello and thank you for contacting Toolset support.

Nigel, our Spanish-speaking supporter is on vacation and won't be able until next week. If you don't mind, we can continue in English.

If I understood well, you are unable to edit the last query filter(busqueda de entrada). The filter that cannot be edited has a search filter in the Search and Pagination section. Check this screenshot hidden link

If you need to edit it, remove the search filter, and you will be able to remove it from the query filter section. And then, you can add it again.

I hope this helps. Let me know if you have any questions.

#2122185

Hello, Okay, the problem is that after the last plug-in update each new views that I create already comes with these predefined filters where I cannot change the search filter and I don't understand why the views already come out with a predefined filter when before it was not like that.

#2122447
Captura de pantalla 2021-07-22 a las 16.29.59.png

Also another error that is bothering me too much is: Every time I want to modify an entry I get an error "The update has failed. The answer is not a valid JSON response.

This is not the same problem that I mentioned before, but I will put it in this same thread to speed up the solution to my problems, thank you very much.

New threads created by Jamal and linked to this one are listed below:

https://toolset.com/es/forums/topic/unable-to-edit-any-entry/

#2123141

Jamal
Supporter

Languages: Inglés (English ) Francés (Français )

Timezone: Africa/Casablanca (GMT+01:00)

The last updates will freeze any query filter that has a corresponding search filter inside the view. This is to make the experience consistent because you cannot set a query filter(with predefined configs) and also have a search filter on it. As long as you have a search filter on a taxonomy or custom field, its corresponding query filter will not be editable.

Let me log into your website and check if those frozen query filters have, or not, corresponding search filters.

However, for support rules, we are able to handle only one issue at a time. This helps us to bring you a better service and also helps other users to find all the information here exposed. For that reason, I have created another ticket for your last solution.

#2123809

Ok, I'll give you access to the web. Can you send me the message to insert account and pass? Thanks

#2123833

Jamal
Supporter

Languages: Inglés (English ) Francés (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Sure. Your next reply will be private to let you share credentials safely.

#2123865

Jamal
Supporter

Languages: Inglés (English ) Francés (Français )

Timezone: Africa/Casablanca (GMT+01:00)

I confirm the credentials are working. I just need to know what view are you working on? And where it is being used?

#2126271

It seems that I found the solution, practically I am duplicating the pages and then I delete and create a new views to keep the content as banner and texts and change the views for a new one with new parameters.

It seems that when I do that if I don't save the page before creating the new views it gives me this error.

now a new question arises ...

Is there no way to create a "mother page" that I then load to each page I create and change only the parameters of the views?

#2126485

Jamal
Supporter

Languages: Inglés (English ) Francés (Français )

Timezone: Africa/Casablanca (GMT+01:00)

I am not sure to understand your question, but I must say, that a view is independent of its parent page or content template. Basically, a view is a post from a hidden custom post type. If you update it, it will get updated wherever it is used. However, you can copy/duplicate a view.

If this does not answer your question, please elaborate more on it to help me understand it better.

#2126631

Okay.

I got this email from wordpress:

Hello!

Since WordPress 5.2 there is a built-in feature that detects when a plugin or theme causes a fatal error on your site and alerts you via this automated email.

In this case, WordPress has detected an error with one of your plugins, Toolset Types.

First, visit your website (hidden link) and check if there are any visible problems. Next, visit the page where the error was detected (hidden link) and check if there are any visible problems.

Please contact your property to help you further investigate this issue.

If your site seems broken and you cannot access your desktop normally, WordPress now has a special "recovery mode". This allows you to safely access your desktop and investigate further.

hidden link

To keep your site safe, this link will expire in 1 day. However, don't worry about this: you will receive a new link by email if the error occurs again after it expires.

When looking for help with this problem, you may be asked for the following information:
WordPress version 5.8
Current topic: GeneratePress (version 3.0.2)
Current plugin: Toolset Types (version 3.4.10)
PHP version 7.3.29

#2128661

Hello, can you tell me what happens with toolset type or do I have to open another thread?
Thanks

#2129771

Jamal
Supporter

Languages: Inglés (English ) Francés (Français )

Timezone: Africa/Casablanca (GMT+01:00)

My apologies for the late reply, but I do not work on Wednesdays and Thursdays as you can see on my profile page https://toolset.com/es/forums/users/jamal-b/

I am checking what may be causing this issue and I'll get back to you as soon as possible. I might need FTP access to your website, please update the reply where

If it is not related to the original request of this ticket I'll split another thread from this one and I'll post my reply there.

#2130245

Okay, thank you very much. I waited for your answer.

#2130325

Jamal
Supporter

Languages: Inglés (English ) Francés (Français )

Timezone: Africa/Casablanca (GMT+01:00)

I could not find any logs about this error. And without error logs, we can't really tell what is this error.

I wonder if you received this message only one time or too many times?

If you received this email too many times, we'll need to know what triggers this issue. Can you tell what page(s) or the steps to follow to trigger the error again?

If you did receive it only one time, I suggest ignoring it for now.