Skip Navigation

[Resuelto] Falla la dirección de logeo en sistema de mensajeria de toolset

Este es el foro de soporte técnico para Toolset: un paquete de plugines para el desarrollo de sitios WordPress sin escribir PHP.

Cualquier persona puede leerlo, pero solo los clientes de Toolset pueden publicar en este foro. El soporte de Toolset atiende 6 días a la semana, 19 horas por día.

This topic contains 5 respuestas, has 2 mensajes.

Last updated by mauricioH-2 hace 1 mes.

Assigned support staff: Nigel.

Autor
Mensajes
#2089845

Tell us what you are trying to do? Instale y configures el sistema de mensajería interna de toolset. Todo funciona bien pero me falla cuando quiero contestar un mensaje y me pide logearme, al usar el link que trae por defecto el sistema me lleva a una pagina llamada hidden link

Is there any documentation that you are following?
https://toolset.com/documentation/legacy-features/miscellaneous/how-to-create-a-messaging-system-with-toolset/
Is there a similar example that we can see?

What is the link to your site?
psicolat.com

#2090107

Nigel
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/London (GMT+01:00)

Hola Mauricio

Déjame crear un sitio de prueba con el mismo para ver si puedo reproducir el problema, y te contesto de nuevo un poco más adelante.

#2090413

Nigel
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/London (GMT+01:00)

No sé si hace sentido "quiero contestar un mensaje y me pide logearme".

Si no estás logueado, ¿cómo ves un mensaje en primer lugar? Si no estás logueado, ni tienes ni ves mensajes para contestar.

La situación donde aparece un enlace para visitantes no logueados es en el archivo de autor que incluye un formulario para mandar mensaje a este usuario.

Se introduzca en el archivo de autores así:

[toolset_access role="Guest" operator="allow"]
<p>In order to contact author please <a href="[wpv-bloginfo show='url']/login">log in</a>.</p>
[/toolset_access]

¿Has cambiado este código?

#2090725

Gracias Nigel, me pide que me entre como usuario cuando ingreso al sitio a través del link que me envía al correo electrónico. En ese momento me aparece el mensaje "In order to contact author please" pidiendo que me identifique.
No, no he cambiado la url donde esta la pagina de registro. Pero no encuentro donde editar el código que me muestras.
¿Me puedes guiar para llegar y editarlo?

atento a tu respuesta

#2091459

Nigel
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/London (GMT+01:00)

Para mandar un mensaje a un usuario, debes ir al archivo de autor para este usuario (p.j. mi usuario tiene slug 'tssupp', entonces para mandar mensaje a mi un usuario debe ir a site.com/author/tsssup/) donde se encuentra el formulario, ó—si no está logueado—el enlace para loguearse.

Puedes editar el código responsable en WordPress > Archivos de WordPress, donde encontrarás "Author archives", y si editas este archivo verás el código que muestra tal mensaje y enlace.

#2093829

My issue is resolved now. Thank you!