Skip Navigation

[Resuelto] actualicé toolset y el sitio comenzo con errores graves

Este es el foro de soporte técnico para Toolset: un paquete de plugines para el desarrollo de sitios WordPress sin escribir PHP.

Cualquier persona puede leerlo, pero solo los clientes de Toolset pueden publicar en este foro. El soporte de Toolset atiende 6 días a la semana, 19 horas por día.

This topic contains 9 respuestas, has 2 mensajes.

Last updated by andresB-4 hace 2 meses, 3 semanas.

Assigned support staff: Jamal.

Autor
Mensajes
#2105135

Tell us what you are trying to do?

actualicé los plugins de toolset y las funciones que dependen de toolset dejaron de funcionar.
he probado todo lo que está a mi alcance y nada, el sectores del sitio estan muertos.
Por favor, necesito asistencia urgente!

Is there any documentation that you are following?

no

Is there a similar example that we can see?

What is the link to your site?

el link al sitio es hidden link
y el mejor ejemplo para ver que no funciona es el buscador de recetas hidden link
Debería aparecer una grilla con recetas y una caja con opciones para filtrarlas.
Hoy no aparece nada. Y hasta ayer esto funcionaba perfecto.

#2105189

aquí un update de lo que hice pero sigue el problema.
Wordpress me envío por correo los technical issues. Aquí lo reproduzco (eliminé las rutas completas por seguridad):

Error Details
=============
An error of type E_ERROR was caused in line 23 of the file .../us/wp-content/plugins/wp-views/vendor/toolset/toolset-common/utility/dic.php. Error message: Uncaught Error: Class 'OTGS\Toolset\Common\Auryn\Injector' not found in .../us/wp-content/plugins/wp-views/vendor/toolset/toolset-common/utility/dic.php:23
Stack trace:
#0 .../us/wp-content/plugins/wp-views/vendor/toolset/toolset-common/utility/dic.php(45): toolset_dic()
#1 .../us/wp-includes/class-wp-hook.php(287): Toolset_Common_Bootstrap::{closure}(NULL)
#2 .../us/wp-includes/plugin.php(206): WP_Hook->apply_filters(NULL, Array)
#3 .../us/wp-content/plugins/wp-views/vendor/toolset/toolset-common/utility/dic.php(70): apply_filters('toolset_dic', NULL)
#4 .../us/wp-content/plugins/wp-views/vendor/toolset/toolset-common/bootstrap.php(278): require_once('/var/sftp/proje...')
#5 .../us/wp-content/plugins/wp-views/vendor/toolset/toolset-common/bootstrap.php(94): Toolset_Common_Bootstrap->register_inc()
#6 .../us/wp-content/plugins/wp-views/vendor/t

Busqué una versión anterior y la instalé, pero el problema persiste.

#2105563

Jamal
Supporter

Languages: Inglés (English ) Francés (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello and thank you for contacting Toolset support.

Nigel, our Spanish talking supporter does not work on the weekend. If you don't mind, I'll continue with you in English. If you prefer to keep this thread in Spanish, I'll assign it to Nigel who will be available on Monday.

From these errors, and because a previous version still reproduces issues, I think that the update was not completed correctly. Some files are missing. I'll suggest the following:
- Remove all the existing Toolset plugins. This will not remove the data from the database.
- Download and install Toolset Types from the download page https://toolset.com/es/account/downloads/
- Activate it, and go to the Toolset Installer at Plugins->Add New->Commercial(tab).
- Install and activate the other needed plugins(Views, etc.).

If this does not help fix the issue, please allow me temporary access to your website. I'll also need FTP access. And I'll check this further. Your next reply will be private to let you share credentials safely. ** Make a database backup before sharing credentials. **

If I can't fix it on your website, I might need to migrate it into our platform or take a copy and debug it locally. Let me know if that's fine with you.

#2106431

Jamal
Supporter

Languages: Inglés (English ) Francés (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello Andres, and thank you for the credentials. I confirm they are working for me.

It seems that the Fatal errors have been fixed. I assume that you have installed Toolset plugins again, right?

All I can see are warnings and notices that are somehow related to Divi. I wonder if you were able to check these pages in a minimal setup(default theme+only Toolset plugins). It seems to me that they are related to Divi or maybe to a 3rd party plugin related to Divi.

To better analyze this, and because I don't have FTP access, I prefer to take a copy of your website and analyze it locally. Let me know if that's fine with you.

#2106605

Hi Jamal, yes, please, go ahead and make that copy to analyze it.

#2106691

Do you think that rolling back DIVI theme to previous version could solve this issue? I believe we've updated the theme and maybe this is the reason why it is failing. I can talk to divi's support about this.

#2106787

Jamal
Supporter

Languages: Inglés (English ) Francés (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Well, I believe the issue comes from a combination of Toolset and Divi, and it is caused by using a function that was introduced in WordPress 5.5. The function is wp_filter_content_tags

[05-Jul-2021 08:37:09 UTC] PHP Warning:  call_user_func_array() expects parameter 1 to be a valid callback, function 'wp_filter_content_tags' not found or invalid function name in /var/sftp/projects/v2usa/us/wp-includes/class-wp-hook.php on line 289

I believe that updating WordPress to 5.5 will fix the issue. Currently, you are using 5.4.6. And the latest version is 5.7.2.

Otherwise, downgrading Divi may help. Otherwise, downgrading both Divi and Toolset views may help.

Let me know what you will do/get.

#2106821

PLEASE! Can you try fixing this? I don't know what else to do. I've rolled back to previous version of divi theme but the problem is still there.

#2106871

Jamal
Supporter

Languages: Inglés (English ) Francés (Français )

Timezone: Africa/Casablanca (GMT+01:00)

On the local copy that I was analyzing, I fixed the following warning by updating WordPress to the latest release:

[05-Jul-2021 08:37:09 UTC] PHP Warning:  call_user_func_array() expects parameter 1 to be a valid callback, function 'wp_filter_content_tags' not found or invalid function name in /var/sftp/projects/v2usa/us/wp-includes/class-wp-hook.php on line 289

There are still other warnings that are generated even after deactivating Toolset plugins. This means that Toolset is not causing any of them.

Then I deactivated the "4DIVI Masonry Custom Post" plugin, and all those warnings disappeared.

I activated Toolset plugins again and both pages have opened without issues. And no messages were generated in the logs file. My conclusion: The issues come from the outdated WordPress version and from the 4DIVI Masonry Custom Post plugin.
- /recipe/pulled-pork-sanwiches-with-orange-and-grape-fruit-salad/
- /recipe-finder/

#2107023

My issue is resolved now. Thank you Jamal!