Skip Navigation

[Résolu] WordPress 4.5 and WooCommerce

Ce fil est résolu. Voici une description du problème et la solution proposée.

Problem:
How to install a Framework on a new or existing WordPress Site?

Solution:
1. Reset your DDBB

2. Clean out all Plugins you have in your FTP (All Toolset, all Plugins, if you don't have any content best is,
reset/re-install the whole WordPress)

3. Install all Plugins from here:
https://toolset.com/account/downloads/
(you need Views, Layouts, Access, Maps and CRED + Types)

4. Get the Framework Installer from above same page

5. In your WP Admin, activate the Framework installer

6. If requested, reset the DDBB again

7. Activate and run the Framework installer

8. Install your preferred Test Site

Relevant Documentation:
https://toolset.com/forums/topic/fatal-error-call-to-undefined-function-render_view/#post-371355

This support ticket is created Il y a 6 années et 9 mois. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- - 14:00 – 20:00 14:00 – 20:00 14:00 – 20:00 14:00 – 20:00 14:00 – 20:00
- - - - - - -

Supporter timezone: Asia/Ho_Chi_Minh (GMT+07:00)

This topic contains 10 réponses, has 2 voix.

Last updated by tony Il y a 6 années et 9 mois.

Assigned support staff: Beda.

Auteur
Publications
#391595

I had a working WooCommerce site and wanted to clean it out to load the WooCommerce reference site. It failed and I ended up with a white screen in the back office although the front end does seem to display a page.

I was loading all the latest Toolset plugins and Woocommerce using WP4.5 Most seemed to load and activate until Layouts.

All a bit of a mess so I managed to find another domain and repeated the exercise. I seem to have a problem with WP4.5 not working with Tooset plugins and possibly also WooCommerce. At one point when trying to activate WooCommerce I got a fatal error message on activation.

I am not sure where I go from here - it is possible that there is something wrong at my end but wondered if anyone else was having similar WP4.5 problems.

I cannot log in to either site - white screen.

#391599

Added information.

I deleted the Woocommerce and Toolset WooCommerce Views and I can get back in to the website back office. However, when I try download WooCommerce Views it just hangs on "Installing".

If I download WooCommerce that seems to work but when trying to activate, I get the white screen.

#391603

OK I got a bit further and managed to download WooCommerce Views leaving it deactivated.

I went to framework and started the WooCommerce site install and saw a timeout message and it is now stuck displaying
1. Downloading and importing Types...
2. Downloading and importing Posts and Images...
3. Downloading and importing Views...
4. Downloading theme...
5. Downloading and importing module manager...
6. Finalizing imported settings...

stuck on item 2

Cancelled it and now I am back to a white screen.

Removed WooCommerce and WooCommerce Views and I get back in.

#391671
toolset-23-apr-2016.jpg

I rolled back to WP4.4 and I still have a problem. It is beginning to look like a local server/installation problem so any pointers appreciated.

I have uploaded an image of the attempted load of the demo site. Are you able to tell me what is missing or should I just get the whole site rebuilt?

Thanks
Tony

#391723

I ran another series of tests and discovered that my problem is connected to layouts and woocommerce.

They will not co-exists as active plugins. I can activate one or the other but not both.

#391744

Layouts and WooCommerce can co-exist, I run them on may Sites and also locally, all with WordPress 4.5 and the latest WooCommerce + Toolset

Firstly, I must know what sort of "fatal" you receive.

The exact pasted error will tell me what is the issue.

Also, we need to separate the issues here.

1. One issue is a Fatal error on activation of Toolset and WooCommerce on WordPress 4.5, when the Toolset Plugins are downloaded and installed from here:
https://toolset.com/account/downloads/

2. The second issue is the Installation of a framework which is not related to first issue.

For the Frameworks to work you need all Toolset Plugins required and a FRESH Database, which you can achieve by resetting the Database with the Framework Installer

For this second issue, please open a new ticket if persistent.

Can you let me know your Fatal Error, on activation of Toolset, WooCommerce and WordPress 4.5?

Thank you

#391848
toolset-01.jpg

Thanks Beda

The fatal error has not been seen since the first time it appeared.

My problem is that activation of Framework with WooCommerce ends up with me seeing a white screen.

I reset the database, which deactivates all of my plugins. I them activate them (see image) so that the only plugin not activated is Woocommerce.

At this point I try to activate Woocommerce and get a white screen.

It is quite possible that there is something wrong at my end but I have tried many combinations and cannot get past being able to activate Woocommerce and Framework Installer at the same time.

Tony

#392072

Whenever you receive a White page of Death there is in 99% of cases a fatal PHP Error.
Please enable WP Debug and tell me the error.
https://codex.wordpress.org/WP_DEBUG

To install a Framework Successfully on your Website please follow this steps:
https://toolset.com/forums/topic/fatal-error-call-to-undefined-function-render_view/#post-371355

BTW I can not ready our ScreenShot and it's warning, the resolution seems too low.

Thank you

#392192

Thanks Beda

I have activated debug and here is a list of actions that I took:

My start point is a domain with WP4.5 and the following plugins activated:

Toolset CRED 1.6
Toolset Types2.0.1
Toolset Views 2.0
Toolset WooCommerce Views 2.6.0
WooCommerce 2.5.5

I then downloaded

Toolset Layouts 1.6
Toolset Module Manager 1.6.5
Toolset Framework Installer 1.9.8

I activated Toolset Module Manager - worked

I activated Toolset Layouts -

Fatal error: Allowed memory size of 83886080 bytes exhausted (tried to allocate 122880 bytes) in /home/hotelacc/public_html/wp-content/plugins/cred-frontend-editor/embedded/toolset/toolset-common/expression-parser/parser.php on line 1045

I removed Toolset Layouts and reinstated it as an deactivated plugin.

I then activated Toolset Framework Installer - seemed to work as it showed me all of the reference sites, each displaying the comment "Installation requirements not met. Click for details"

I noticed that one missing component of the WooCommerce reference site was Toolset Comment Validator and so I loaded that and activated it.

I was then taken to:

=====================================================
Installing Plugin from uploaded file: toolset-comment-validator.0.5.zip
Complete Framework Installer setup
Framework Installer theme uses Toolset technology. To complete its setup, Framework Installer needs to load several items.

Install Toolset Embedded plugins
Activate Toolset Embedded

Unpacking the package…

Installing the plugin…

Plugin installed successfully.

Activate Plugin | Return to Plugins page
======================================================

I clicked the Start button (Framework Installer setup) and the button changed to "Running".

After a minute I clicked "Activate Plugin" and returned to the Plugins.

I deactivated Toolset Framework Installer and reactivated it and was asked to reset the WP Database, which I did. I then returned to WP Plugins page where all plugins were deactivated. I activated:

WooCommerce
Types
Cred
Views
WooCommerce Views
Comment Validator
Module Manager
Framework Installer

where I was asked to reset my database again, even though it had recently been reset.

I clicked Start again which changed to Running and after a minute I went back to plugins page where the only plugin not activated was Layouts. I activated it and received no debug message, just a white screen.

#392220

Hi Beda

I have managed to solve the plugin activation problem - it was a memory limit that was hidden in the config file.

What I cannot seem to get round is the selection of the reference site that I want. I am asked to reset the database, which I do. I then reactivate all of the plugins and go back into Framework Installer and it asked me to reset the database again.
================
This demo site can't be installed. Please ensure that you meet all plugin and site requirements before installing a demo site. To reset your Website and Database from a previous installation, you can use the reset feature under 'Manage sites –> Reset Demo Site'.
================

I seem to be stuck in a loop.

Regards
Tony

#392432

You would need to follow the exact instructions as I posted in the above linked thread, also here for reference:
https://toolset.com/forums/topic/fatal-error-call-to-undefined-function-render_view/#post-371355

Now, if you might allow me to do this for you?

1. I would need to request temporary access (WP-Admin and FTP) to your site
in order to be of better help

Your next answer will be private which means only you and I have access to it.

❌ Please backup your database and website ❌

2. Elaborate exactly what Framework you want

3. I will completely reset the Database and install it for you.

Thank you