Skip Navigation

[Résolu] Using the new Divi Block in Toolset block based templates

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

No supporters are available to work today on Toolset forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

This topic contains 6 réponses, has 2 voix.

Last updated by Waqar Il y a 1 an et 7 mois.

Assigned support staff: Waqar.

Auteur
Publications
#1453169

On Thursday Divi 4.1 was released with the addition of the new Divi Layout block. This will now allow you to add Divi based elements into the the block editor. Good, and I was already seeing uses cases for this whereby I could create a custom post type and apply a light weight block template. To the end of this I could add a Divi block with the contact form built in using the form title dynamically pulling in the post title and the subject line also dynamically including the title.

I spotted this post today:

https://toolset.com/2020/01/how-to-build-advanced-sites-with-toolset-and-divi/#comments

This looks good too except for the caveat of not mixing Toolset content with Divi in the block editor. I do wonder about this though? So I did a test and with a block template and I see that the new Divi block is not available? I do notice that every other block, Kadence, Koiken, Block Gallery, Getwid are available (yes a lot of additional blocks, the site is for testing things out).

This whole compatibility between Divi and Toolset is really becoming painful, like never the twain shall meet.

#1455461

Waqar
Supporter

Languages: Anglais (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Stephen,

Thank you for bringing this to our attention.

Since this new block from Divi is a fairly recent development, I don't have much information about it, at the moment.

But, I've passed this feedback to the concerned team and will keep you updated through this ticket.

regards,
Waqar

#1484065

Waqar
Supporter

Languages: Anglais (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Stephen,

I'd to like update that a fix for this will be covered in the next version of Toolset Views & Blocks.

A patch is also available meanwhile, at:
https://toolset.com/errata/the-divi-layout-block-is-missing-when-editing-a-content-template/

I'll let you know once it releases.

regards,
Waqar

#1484405

Hi Waqar,

Thanks for the update. Apart from the Divi layout block being available, have Toolset tested that it fully works?

I have been able to swap out the files in the patch on two sites, one on Varying Vagrant Vagrants and another on my SiteGround hosting. In both instances I can load the Divi block but when I activate it to load the Divi builder, the spinning Divi loader appears for ages and eventually arrives at a blank interface. The top bar with the close X is the only element visible. I also tested loading a layout with the pre-made template interface and it takes ages to load…nothing?

I will try again later. I do know that the VVV local server can be temperamental and my SiteGround hosting looks very sluggish today, so perhaps some sort of time outs. I have tested with main Divi theme installed and all other plugins off.

Again can you confirm that the patch actually works, beyond just being able to access and put the Divi block into the block editor.

#1498037

Waqar
Supporter

Languages: Anglais (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Stephen,

I was checking my follow-up list and came across this ticket.

I understand that you're aware by now that the missing Divi block is now available.

You're welcome to mark this ticket as resolved and for the other report ( ref: https://toolset.com/forums/topic/patch-for-divi-layout-block-in-toolset-block-template-not-functioning-fully/ ), we'll continue investigation through that relevant ticket.

regards,
Waqar

#1498049

Good afternoon.

I will be frank... I feel I am going around in circles on this one and it is a bit irritating.

Go back and read my run through of the issue, illustrated with screenshots. As you will see the Divi block is now available, and while it does work in regular pages and posts, inside block templates it doesn't function properly. The Divi template builder won't load. I have tested this across several sites, browsers and from different types of pc.

#1501115

Waqar
Supporter

Languages: Anglais (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Stephen,

I can understand the frustration involved with compatibility issues like this, which require very specific parameters/environments.

During the initial investigation, some of our team members were able to reproduce this on their test websites and others were not, but as Luo mentioned in the other ticket, it is already escalated and we'll include a needed fix, after thorough investigation and testing.

Thank you for reporting it and Luo will keep you updated with the progress through the other ticket.
( ref: https://toolset.com/forums/topic/patch-for-divi-layout-block-in-toolset-block-template-not-functioning-fully/ )

Now coming back to this particular ticket, it started with a report about the missing Divi Layout block, which is now available. So I'm sure you'll agree that this ticket can be marked as resolved and any underlying usability and compatibility issues will need to be discussed through their own respective tickets.
( just as you rightly did and started a new one )

I hope this explanation will make it more clear.

regards,
Waqar