Skip Navigation

[Résolu] Uncaught RangeError: Maximum call stack size exceeded

Ce fil est résolu. Voici une description du problème et la solution proposée.

Problem:
While displaying Toolset Maps on a page using View, I am getting this error:
Uncaught RangeError: Maximum call stack size exceeded

Solution:
This problem happened between Google Maps API and WordPress due to wrong timezone being set in theme’s functions.php file. Instead, you should set the Timezone from WP Dashboard >> Settings >> General >> Timezone option - Screenshot here:
https://d7j863fr5jhrr.cloudfront.net/wp-content/uploads/2017/05/527861-Timezone.png

- The first thing to check in such case is the theme and plugin conflicts. In this forum ticket, following code caused the problem and removing this resolved it:

// set the default timezone to use.
date_default_timezone_set('America/Montreal');
setlocale(LC_ALL, 'fr_CA');

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

No supporters are available to work today on Toolset forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

This topic contains 4 réponses, has 2 voix.

Last updated by marc-andre Il y a 4 années et 3 mois.

Assigned support staff: Noman.

Auteur
Publications
#527514

SIte in maintenance mode
to ge in here is the infos :
[ Credentials Removed ]

go to : hidden link

55 marker show up
what i need is the category for map to show up, when filter, I got an error
hidden link

Uncaught RangeError: Maximum call stack size exceeded
at hy._.k.zoom_changed (map.js:42)
at Hb (js:38)
at hy._.k.set (js:101)
at iy (map.js:12)
at hy._.k.zoom_changed (map.js:42)
at Hb (js:38)
at hy._.k.set (js:101)
at iy (map.js:12)
at hy._.k.zoom_changed (map.js:42)
at Hb (js:38)
at hy._.k.set (js:101)
at iy (map.js:12)
at hy._.k.zoom_changed (map.js:42)

shortcode used : [wpv-view name="map-filter" nom="artistes-et-artisans" cached="off"]

help need fast, because this ticket have been open in french and i got no help ... i need to reopen it in english to get help (as request by your support staff)

#527625

Noman
Supporter

Languages: Anglais (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Marc,

Thank you for contacting Toolset Support. I would be happy to help you in resolving this.

I have thoroughly debugged the issue, checked for theme and plugin conflict. I have only activated Toolset plugins (also Maintenance & Post Types Order) and switched to Twenty Fifteen theme. Now when we check the page there is no error in console and map also showed up without any problem:
hidden link

- The above test shows that there is something wrong in the theme or the custom functions that you have added in the theme.
- It could also be happening due to other plugins which are in return using lots of resources on the server and hence breaking the page.

Thank you

#527638

OK with you help and change you made, i troubleshoot my functions.php file and i found that REMOVING theses line fix the problem....

// -------------------------------------------------
// set the default timezone to use.
date_default_timezone_set('America/Montreal');
setlocale(LC_ALL, 'fr_CA');
//obligatoire pour que les evenement a venir soit a la bonne date

the problem is i NEED these to setup my server date...

so back to square ONE, can you fix the rangeError WITH local set to FR

#527861

Noman
Supporter

Languages: Anglais (English )

Timezone: Asia/Karachi (GMT+05:00)

Timezone.png

Hello Marc,

You can set the Timezone from WP Dashboard >> Settings >> General >> Timezone option (please see attached screenshot).

I am not sure if we really need the above code that you are using in the site, because timezone you can already set in your WP site through above settings.

Thank you

#528123

ok then i remove the : setlocale(LC_ALL, 'fr_CA'); and it'S fine now ! thanks