Skip Navigation

[Résolu] Set URL in Advanced Custom Field to Div Background Image

This support ticket is created Il y a 5 années et 10 mois. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Our next available supporter will start replying to tickets in about 1.30 hours from now. Thank you for your understanding.

Sun Mon Tue Wed Thu Fri Sat
- 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Kolkata (GMT+05:30)

Marqué : ,

This topic contains 2 réponses, has 2 voix.

Last updated by Minesh Il y a 5 années et 10 mois.

Assigned support staff: Minesh.

Auteur
Publications
#479558

I am trying to: Set a url in a Advanced Custom field to be the background image of a Div in a view.

I visited this URL: hidden link

I expected to see: background image in the first column of each row (other three columns just have it set to load the image; not as a background)

Instead, I got: blank div.

#479560

Minesh
Supporter

Languages: Anglais (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello. Thank you for contacting the Toolset support.

Can I have your field name and few screenshots where exactly you want to display your background image.

*** Please make a FULL BACKUP of your database and website.***
I would also eventually need to request temporary access (WP-Admin and FTP) to your site. Preferably to a test site where the problem has been replicated if possible in order to be of better help and check if some configurations might need to be changed.

I would additionally need your permission to de- and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important. If you agree to this, please use the form fields I have enabled below to provide temporary access details (wp-admin and FTP).

I have set the next reply to private which means only you and I have access to it.

#479819

Minesh
Supporter

Languages: Anglais (English )

Timezone: Asia/Kolkata (GMT+05:30)

Well - you used following code - that is wrong:

[wpv-acf-image field='wac_image' size='large' url='true'][/types]

You can get your ACF field image using following shortcode:

[wpv-post-field name='wac_image']

More info:
=> https://toolset.com/documentation/user-guides/views-shortcodes/#wpv-post-field