Skip Navigation

[Résolu] Put ‘edit form’ on another page and click edit on a front end post and redirect

Ce fil est résolu. Voici une description du problème et la solution proposée.

Problem:

The issue here is that the user wanted to add an edit button on their page so when they click the button it goes to the edit page with the form.

Solution:

This can actually be done by following the instruction in the link below. https://toolset.com/documentation/getting-started-with-toolset/publish-content-from-the-front-end/forms-for-editing/

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Our next available supporter will start replying to tickets in about 1.62 hours from now. Thank you for your understanding.

This topic contains 7 réponses, has 2 voix.

Last updated by susanT-4 Il y a 2 années et 4 mois.

Assigned support staff: Shane.

Auteur
Publications
#1252167

I am trying to do this "Adding an edit link to templates that display single items": https://toolset.com/documentation/getting-started-with-toolset/publish-content-from-the-front-end/forms-for-editing/

I am using Beaver Themer to style my CPT, so I'm not getting the Using the Content Type dropdown

#1252205

Shane
Supporter

Languages: Anglais (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Susan,

Thank you for getting in touch.

What you can do is to add this shortcode to your BB template.

[toolset-edit-post-link content_template_slug='edit-car' target='self']Edit %%POST_TITLE%%[/toolset-edit-post-link]

Where you you will replace content_template_slug='edit-car' with the slug of your content template that holds the edit form.

Have you setup the content template with the edit form?

Please let me know.
Thanks,
Shane

#1252213

Thank you! No I have not yet. I have been playing around with toolset and haven't gotten to that step yet. I'm assuming it have to do it that way and I can't just put the form on another page (because the other page won't know what post it is supposed to edit?)

#1252293

Shane
Supporter

Languages: Anglais (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Susan,

Yes you will need to do it this way by using the content template.

However you can style the content template in whatever way you want .

Thanks,
Shane

#1252295

Thank you. I will try later today and report back.

#1253219
Screen Shot 2019-05-29 at 10.11.40 AM (1).png

Ok, so I figured it out what I was supposed to do here: https://toolset.com/documentation/user-guides/using-toolset-with-beaver-builder/designing-templates-for-custom-post-types-and-custom-fields-with-beaver-builder/

FYI, I was using Beaver Themer to do my templates, not Content Template from Toolset. I saved my layout and imported it into the Content Template. All good there.

Now back to the original problem. I put in that shortcode you gave me above, but it just disappears/displays nothing.
hidden link

Attached is where it is supposed to show up in the link above.

#1253333

Never Mind! I figured it out myself. I had the wrong slug in there. I changed it and forgot to change the shortcode. Still strange that it disappeared, but all good! 🙂

#1253335

My issue is resolved now. Thank you!