Skip Navigation

[Fermé] PHP 7.0

C'est le forum d'assistance technique pour Toolset : une suite de plugins pour développer des sites WordPress sans écriture PHP.

Tout le monde peut consulter ce forum, mais seuls les clients Toolset peuvent publier des messages dessus. L'assistance Toolset est opérationnelle 6 jours par semaine, 19 heures par jour.

Marqué : 

This topic contains 1 réponse, has 2 voix.

Last updated by Luo Yang Il y a 4 années et 2 mois.

Assigned support staff: Luo Yang.

Auteur
Publications
#524330

Hello

i would like to set my website on PHP7 but i got errors & warning when i run a tst,

is it possible to fix those , to be able to go on PHP7 on my website

Thanks

FILE: /home/commonp4/public_html/commonplacesartgallery.com/wp-content/plugins/types-access/toolset/toolset-common/toolset-forms/js/recaptcha-php-1.11/recaptchalib.php
-----------------------------------------------------------------------------------------------------------------------------------------------------------------------
FOUND 0 ERRORS AND 2 WARNINGS AFFECTING 1 LINE
-----------------------------------------------------------------------------------------------------------------------------------------------------------------------
221 | WARNING | Function mcrypt_encrypt() is deprecated since PHP 7.1; use OpenSSL instead
221 | WARNING | Extension 'mcrypt' is deprecated since PHP 7.1 - use openssl (preferred) or pecl/mcrypt once available instead.
-----------------------------------------------------------------------------------------------------------------------------------------------------------------------

FILE: /home/commonp4/public_html/commonplacesartgallery.com/wp-content/plugins/types-access/toolset/toolset-common/toolset-forms/lib/CakePHP-Validation.php
-------------------------------------------------------------------------------------------------------------------------------------------------------------------------
FOUND 0 ERRORS AND 2 WARNINGS AFFECTING 2 LINES
-------------------------------------------------------------------------------------------------------------------------------------------------------------------------
1168 | WARNING | Method name "WPToolset_Cake_Validation::__populateIp" is discouraged; PHP has reserved all method names with a double underscore prefix for future use
1199 | WARNING | Method name "WPToolset_Cake_Validation::__reset" is discouraged; PHP has reserved all method names with a double underscore prefix for future use
-------------------------------------------------------------------------------------------------------------------------------------------------------------------------

FILE: /home/commonp4/public_html/commonplacesartgallery.com/wp-content/plugins/types-access/toolset/toolset-common/classes/validation-cakephp.php
--------------------------------------------------------------------------------------------------------------------------------------------------------------------
FOUND 0 ERRORS AND 2 WARNINGS AFFECTING 2 LINES
--------------------------------------------------------------------------------------------------------------------------------------------------------------------
1098 | WARNING | Method name "Wpcf_Cake_Validation::__populateIp" is discouraged; PHP has reserved all method names with a double underscore prefix for future use
1129 | WARNING | Method name "Wpcf_Cake_Validation::__reset" is discouraged; PHP has reserved all method names with a double underscore prefix for future use
--------------------------------------------------------------------------------------------------------------------------------------------------------------------

FILE: /home/commonp4/public_html/commonplacesartgallery.com/wp-content/plugins/types-access/toolset/toolset-common/inc/toolset.assets.manager.class.php
-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------
FOUND 0 ERRORS AND 2 WARNINGS AFFECTING 2 LINES
-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------
335 | WARNING | Method name "Toolset_Assets_Manager::__initialize_styles" is discouraged; PHP has reserved all method names with a double underscore prefix for future use
471 | WARNING | Method name "Toolset_Assets_Manager::__initialize_scripts" is discouraged; PHP has reserved all method names with a double underscore prefix for future use
-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------

FILE: /home/commonp4/public_html/commonplacesartgallery.com/wp-content/plugins/types-access/toolset/toolset-common/lib/cakephp.validation.class.php
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------
FOUND 0 ERRORS AND 2 WARNINGS AFFECTING 2 LINES
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------
1096 | WARNING | Method name "Toolset_CakePHP_Validation::__populateIp" is discouraged; PHP has reserved all method names with a double underscore prefix for future use
1127 | WARNING | Method name "Toolset_CakePHP_Validation::__reset" is discouraged; PHP has reserved all method names with a double underscore prefix for future use
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------

FILE: /home/commonp4/public_html/commonplacesartgallery.com/wp-content/plugins/types-access/loader.php
------------------------------------------------------------------------------------------------------
FOUND 1 ERROR AFFECTING 1 LINE
------------------------------------------------------------------------------------------------------
381 | ERROR | Global with variable variables is not allowed since PHP 7.0

#524640

Luo Yang
Supporter

Languages: Anglais (English ) Chinois simplifié (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Dear Silvia,

Thanks for the feedback, I can see the Access plugin is using PHP function mcrypt_encrypt() in the source code, and you are right, and this function has been DEPRECATED as of PHP 7.1.0:
hidden link

But I need details to duplicate the same problem in my localhost, and I just tested the latest version of XAMPP server with PHP 7.1.4 + Access plugin + Fresh wordpress installation, but can not see similar warning message

Please check these:
1) deactivate other plugins and switch to wordpress default theme
2) if the problem persists, please try these
a) provide a database dump file of your website in below "private detail box", also point out how and where I can see the warning message
b) provide the debug information of your website in below
https://toolset.com/faq/provide-debug-information-faster-support/

Le sujet ‘[Fermé] PHP 7.0’ est fermé à de nouvelles réponses.