Skip Navigation

[Résolu] Need to reassign custom posts to a different WP user

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 6 réponses, has 2 voix.

Last updated by Shane Il y a 4 années et 11 mois.

Assigned support staff: Shane.

Auteur
Publications
#443358

I am trying to: I have some posts created in a custom post type. I (as the admin) created them - but I need to change the ownership of them to other WP user accounts now the site is live

I visited this URL: I've looked at the post edit page, and there's no facility apparent to change ownership

I expected to see: Post over field

Instead, I got: nothing!

#443449

Shane
Supporter

Languages: Anglais (English )

Timezone: America/Jamaica (GMT-05:00)

Hi McCarthy,

Thank you for contacting our support forum.

In order to do this you need to enable authors on your screen options. Scroll all the way to the top of your edit page and in the top right hand corner you will see "Screen Options".

You simply need to click this and enable Authors and then scroll to the authors field on the page. From here you can change owner of the post.

Please let me know if this helps.
Thanks,
Shane

#443765

Hi Shane
I'd thought of that, but the 'author' option isn't shown in the pull-down 'screen options'.

So ... I've had a look at the 'Edit Post type' for the custom post, and noticed in 'Sections to display when editing' there's an 'Author' section - ticked this, and I can now see the author.

However, it doesn't show me all users, so I can't change it to the correct username.

The post type is set up so only the author can edit it, but I'm logged in as an administrator, so I was expecting to be able to change this.

What next?

Regards, David

#443812

Shane
Supporter

Languages: Anglais (English )

Timezone: America/Jamaica (GMT-05:00)

Hi McCarthy,

You should be able to change the authors since you are the admin.

Do you have our Access plugin enabled ? If so could you disable it temporarily and see if you are able to change the author ?

It could be that your permissions settings are preventing this.

Thanks,
Shane

#444209

Hi Shane

Access is enabled and it was controlling the post-type. I disabled it (for the post type), but it made no difference. I have looked though the permissions and can't see anything wrong.

The site was built with a few test user accounts. These are the ones which show up as 'author' options. The site has now had about 2,100 accounts migrated in from an old Joomla site - none of these are visible in the 'authors' option.

I don't know enough about WP to understand what could be different about the two sets of users.

If it would help, I can give you access to the development site.

Best regards, David

#444277

Shane
Supporter

Languages: Anglais (English )

Timezone: America/Jamaica (GMT-05:00)

Hi McCarthy,

Yes please provide me with admin access to the website.
The private fields will be enabled for your next response.

Thanks,
Shane

#444878

Shane
Supporter

Languages: Anglais (English )

Timezone: America/Jamaica (GMT-05:00)

Hi McCarthy,

The reason for this is that those imported users are subscribers.

In wordpress subscribers are not allowed to publish posts so you won't be able to assign them as authors.

You will need to change the role of these users to atleast editors for there names to show up.

Please let me know if this helps.

Thanks,
Shane