Skip Navigation

[Résolu] More than 500 post created with CRED Auto Draft in less than one week !

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Marqué : 

This topic contains 13 réponses, has 3 voix.

Last updated by Pat Il y a 1 mois et 4 semaines.

Assigned support staff: Shane.

Auteur
Publications
#1992525

Pat

Hello,
I'm trying to clean my database and found that lots of posts have been created with the title : CRED Auto Draft
Is it normal and if yes, is there a way to avoid this ?
What is the need for Toolset to create such posts?

Regards
Pat

#1992713

Shane
Supporter

Languages: Anglais (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Pat,

Thank you for getting in touch.

Our Toolset Forms plugin won't automatically create a post without any form of interaction. The reason for the autodraft title is that the form could've been created and then submitted without the post title field.

Once the post title field is on the form then the post must be create with a post title. Can you say when these posts were created? Also is the issue currently still occurring ?

Are you able to provide a link to the form on the frontend so that I can have a look ?

Thanks,
Shane

#1994879

Pat
toolset1.jpg

Hi Shane
Thanks for taking care.
I've checked this issue on the last week and every day, I'm getting these kind of posts !
Here is a link where this issue occurs : hidden link

I have attached a screenshot of the database for info!
Regards
Pat

#1996711

Shane
Supporter

Languages: Anglais (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Pat,

Would you mind allowing me to have admin access to this site so that I can have a more detailed look ?

However I can assure you that Toolset won't create autodraft posts without an external interference.

I've enabled the private fields for your next response.

Thanks,
Shane

#1997845

Shane
Supporter

Languages: Anglais (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Pat,

Based on what I see the form is being spammed by russian based bots.

I would suggest that you increase the security of the site by blocking out regions that the site isn't targeting. Based on the site language its geared towards French customers so I would suggest blocking out regions that are not apart of the target audience.

Thanks,
Shane

#2000247

Pat

Hi Shane,

Thanks for your return.
I have added the plugin "iQ Block Country" and defined to block all countries except France and the result is that I'm still having some CRED Auto Draft posts !
Is there a way to avoid this?
Regards
Pat

#2000775

Shane
Supporter

Languages: Anglais (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Pat,

I'm assuming here that you've already deleted the posts that were created. Once this happens again can you let me know and don't delete the posts as yet?

I will like to sample the contents of the Messages Post type to see what is happening this time. Given that i'm not able to access the form from my end means the blocking works.

Once i'm able to see the sample content again I can further advise.

Thanks,
Shane

#2000823

Pat
Toolset1.jpg

Hi Shane,
You're right. All CRED Auto Draft posts have been deleted. Nevertheless, new posts have been created in the database, but no new message postypes are awailable in the wordpress admin! See the screenshot of the database attached?
I have unchecked the country IP blocking and you can now access the site.
Regards
Pat

#2001085

Shane
Supporter

Languages: Anglais (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Pat,

I took a copy of the site to check on the issue further, as well as escalated this to our 2nd tier supporters to see if they can provide any insight on this one for us.

If any autodraft posts appear please do not delete them as we need to check these as well.

Thanks,
Shane

#2064281

Shane
Supporter

Languages: Anglais (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Pat,

Thank you for the continued patience.

This issue has now been resolved

So you should no longer be experiencing this once you're running the latest versions of our plugins.

Thanks,
Shane

#2065393

Pat

Hi Shane,

Thanks for the feedback.
Could you tell me which version of the Form plugin contains this improvement, as I have not been able to find it in the changelog?

Regards
Pat

#2066557

Christian Cox
Supporter

Languages: Anglais (English )

Timezone: America/New_York (GMT-04:00)

Hello, Shane is out for a national holiday today. I took a quick look and it seems this issue was resolved in Forms 2.6.7. If you have follow-up questions about this, Shane will return tomorrow to continue assisting you.

#2067741

Shane
Supporter

Languages: Anglais (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Pat,

Based on the release information in the issue tracker for this, it was fixed in version 2.6.7 of Forms. Now we are on version 2.6.9

You may not see the specific issue being fixed as it could be part of a bigger issue that was fixed.

Thanks,
Shane

#2070847

Pat

Hi Shane,
Thanks for the info. I'm in progress to update all my sites and will check thenafter if no more "CRED Auto Draft" posts are created.
I will come back to you if any issue found.
Regards
Pat