Skip Navigation

[Résolu] Modifying masonry gallery column count will change column count in other masonry galleries on the same page

Ce fil est résolu. Voici une description du problème et la solution proposée.

Problem: When adding various masonry galleries with a different number of columns per grid, setting one to two can also set another one previously set to three to two as well.

Solution: Update to the latest version of Toolset Blocks to receive the fix for this problem.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Marqué : 

This topic contains 4 réponses, has 3 voix.

Last updated by Stephen Vaughan Il y a 11 mois.

Assigned support staff: Christian Cox.

Auteur
Publications
#1690729

Just another observation. When adding various masonry galleries with a different number of columns per grid, setting one to two can also set another one previously set to three to two as well. I eventually figured out that going out of the template and opening it again between adding galleries solved this.

As you can see I managed to set up 7 masonry galleries. Some have two columns, others have three.

hidden link

I currently have the lazy loading for mobile off in SG Optimiser plugin, but would like it on, at least for the rest of the site.

#1691755

Christian Cox
Supporter

Languages: Anglais (English )

Timezone: America/New_York (GMT-04:00)

Thank you for the report about this problem in the block editor. I've been able to replicate it in my own local test environment, and I am escalating the problem to our 2nd tier support team for further investigation. As you've mentioned, a workaround is to save the post/template and refresh the page before editing column counts in Masonry settings for any gallery block. I'll keep you posted as I receive more information about this.

#1692981

Christian Cox
Supporter

Languages: Anglais (English )

Timezone: America/New_York (GMT-04:00)

Okay this problem has been escalated to our developers, who will include a fix in an upcoming release of the software. We are pretty close to code freeze for the current round of updates, so I expect this will not be included in this round of fixes but will be pushed back to the next update. I'll keep you posted as I receive more information about it.

#1817553

Nigel
Supporter

Languages: Anglais (English ) Espagnol (Español )

Timezone: Europe/London (GMT+01:00)

Hi Stephen

We published an update to Blocks 1.3.2 today which includes a fix for this issue, if you'd like to update and verify.

#1817873

My issue is resolved now. Thank you!