Skip Navigation

[Résolu] Message Module – Types field shortcodes appear in email notifications

This support ticket is created Il y a 4 années. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
8:00 – 12:00 8:00 – 12:00 8:00 – 12:00 8:00 – 12:00 8:00 – 12:00 - -
13:00 – 17:00 13:00 – 17:00 13:00 – 17:00 13:00 – 17:00 13:00 – 17:00 - -

Supporter timezone: America/New_York (GMT-04:00)

Marqué : 

This topic contains 5 réponses, has 2 voix.

Last updated by Christian Cox Il y a 4 années.

Assigned support staff: Christian Cox.

Auteur
Publications
#1146559

Thank you Christian - that does the job fine the from/to codes are now correct and I am able to adapt the message system to a membership site with just that one line change.

======
Hi [/types]“],

You have a message from [/types]“] [/types]“].
=======

The code in the email message is:

===========
<p>Hi [wpv-user field="user_firstname" id="[types field='message-to' output='raw'][/types]"],</p>
<p>You have a message from [wpv-user field="user_firstname" id="[types field='message-from' output='raw'][/types]"] [wpv-user field="user_lastname" id="[types field='message-from' output='raw'][/types]"].</p>
<p>Message: [wpv-post-excerpt length="80" more="..."]</p>
<p>This is an automated email, please do not reply to it.</p>
<p>You can reply <a href="[wpv-post-url]">directly here</a>.</p>
============

I don't recall changing this yet so I wondered if there may be a problem with the syntax.

I recall that sometimes " and ' characters can cause problems.

Many thanks
Tony

#1146639

Okay thank you for the report, this looks like a separate bug. I will escalate this and get back to you when I have some further information.

#1146646

Thanks Christian

I thought it might be a bug.

Kind regards
Tony

#1146649

I am updating the ticket status, no need to reply right now.

#1149217

Our developers have released an erratum post and patch files here: https://toolset.com/errata/types-shortcodes-are-not-expanding-in-toolset-forms-notifications/

Please install the patch files as described in the erratum post and let me know if the problem is not completely resolved.

#1150614