Skip Navigation

[Résolu] How to use Toolset and Newspaper theme together

Ce fil est résolu. Voici une description du problème et la solution proposée.

Problem: I'm trying to use Layouts, WPBakery Page Builder, and the Newspaper theme together but I'm not able to get my page templates to appear as expected.

Solution: Toolset Layouts and WPBakery should not be used together, so it's best to deactivate the Layouts plugin. The Newspaper theme doesn't work out-of-the-box with Content Templates, but you can follow the steps in our Theme Support for Content Templates document to help fix that problem.

Add this function name in Toolset > Settings > Frontend Content > Theme support for Content Templates:

td_module_single_base::get_content

Relevant Documentation:
https://toolset.com/documentation/user-guides/theme-support-for-content-templates/

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Our next available supporter will start replying to tickets in about 0.73 hours from now. Thank you for your understanding.

This topic contains 9 réponses, has 3 voix.

Last updated by grigorP Il y a 2 années et 11 mois.

Assigned support staff: Christian Cox.

Auteur
Publications
#1140411
Schermata 2018-11-05 alle 15.06.51.png

I wanted to ask first of all how to get my money back!
You say it's simple but you can not keep going. I lost too much time and money.

Pages visited but with no result.
https://toolset.com/learn/create-business-site-using-toolset/
https://toolset.com/learn/create-business-site-using-toolset/
https://toolset.com/documentation/beyond-the-basics/paginate-lists-of-content/
https://toolset.com/modules/house-search/
https://toolset.com/documentation/user-guides/using-toolset-module-manager/

Post type done
Custom fields: fact
Taxonomy done
  and now? what I do? Where I have to go? What should I change? what options should I put? do I have to install other? do I have to change the code? do I have to log out and then log in? dvo write to my provider? do I have to install other plugins? PD PM?

How do I create layouts? I saw the video, but then I do not see the contents? The information with visual composer does not match?

How are archives created? How do they associate?

But maybe I miss something? is there any incompatibility as in the previous version of php (not compatible with php 7.1 9?

If you can answer me I will be infinitely grateful. The first question and if I can get my money back, this is the most important answer.
The second, to make it short, after having configured the custom files, the tazonomy how to create layouts, as you can see (there are incompatibilities with the theme I use)

I'm sure in your explanation

#1140718

I wanted to ask first of all how to get my money back!
You can go to https://toolset.com/account to log in to your Toolset account. Then visit https://toolset.com/buy/refund-policy/ to request a refund.

The second, to make it short, after having configured the custom files, the tazonomy how to create layouts, as you can see
A Taxonomy archive Layout should include a WordPress Archive cell. Click "Change Layout Usage" at the bottom of the Layout editor to assign a Layout to a Taxonomy Archive.

The information with visual composer does not match?
Do not use Toolset Layouts and Visual Composer (WPBakery Page Builder) together. Choose one or the other, but do not activate both plugins at the same time. More information about using Visual Composer and Toolset together:
https://toolset.com/documentation/user-guides/using-toolset-with-wpbakery-page-builder/

I'll be glad to take a closer look and give you more advice if you would like to provide login credentials for your site here in the private fields.

Please include your debug information with every ticket in the future so we can see your site's configurations, including theme and plugin information. We have a document here that describes how to add the debug information effectively: https://toolset.com/faq/provide-debug-information-faster-support/

#1142304
Screen Shot 2018-11-07 at 8.37.53 AM.png

I can see that a Memcached Redux cache system is being used on your site. There is an object-cache.php file in your wp-content folder. Object caching can store information aggressively to help speed up performance, but it can also cause problems when you are making changes to a site. As a test, please temporarily remove this file to see if the problem is resolved. You can remove this file temporarily with FTP. If that resolves the problem, then we know it's a cache issue. Please let me know the results.

#1143114

Hi, just a quick update to let you know that there seems to be a conflict between the Newspaper theme and Views. If I switch to the Twenty Seventeen theme, the image and custom field values appear as expected on the Basetball post. I am running some additional tests now and will let you know what I find out.

#1143141

Okay it turns out I was able to resolve the problem by following the steps here:
Theme Support for Content Templates (https://toolset.com/documentation/user-guides/theme-support-for-content-templates/)
I added this function name in Toolset > Settings > Frontend Content > Theme support for Content Templates:

td_module_single_base::get_content

Now it appears that Content Templates are being displayed as expected for Ads. Can you confirm?

#1143208

Good morning, the staging site no longer works now. As soon as I can reactivate it, I try it, hoping that it will not compromise the whole site

#1143223

Okay great, I will stand by for your update.

#1143230

My issue is resolved now. Thank you!

#1185957

Hello,

I have the same problem as rodolfod. I am using the Newspaper theme and can't display the custom fields on the custom content type. I checked the function with debugging and it's the same "td_module_single_base::get_content;". I tried adding it with or without ";" and it's not working. When I change the theme back to default ones it's working. Please resolve this for me or I won't be able to use that great module and will ask for a refund as well.

#1185995

Nvm, i figured it out :).