Skip Navigation

[Résolu] Keyword search through custom field type checkboxes

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 21 réponses, has 2 voix.

Last updated by zeljko-turkaljS Il y a 1 an.

Assigned support staff: Nigel.

Auteur
Publications
#1790173

Nigel
Supporter

Languages: Anglais (English ) Espagnol (Español )

Timezone: Europe/London (GMT+01:00)

It looks like your theme is preventing the basic search functionality from working.

Do you have a staging site for testing, this looks like a live site..?

#1790361

Hi Nigel, here it is

hidden link

Please use same credentials as you are using on production environment

Thanks
Sasa

#1790541

Nigel
Supporter

Languages: Anglais (English ) Espagnol (Español )

Timezone: Europe/London (GMT+01:00)

It certainly seems to be the case that the theme is blocking the normal search, and there's not much I can do about that.

Switching theme to twentytwenty, the search does find the text from the checkboxes (I made a test listing post so I could be sure to check that).

That's the good news. The bad news is that the search powered by the View still fails to find such text (the same search as the standard search that works).

I'm taking a copy of your database so I can set up a site locally with the same, it will be easier for me to try and spot what it going on.

#1790575

Thanks Nigel I really appreciate your help

Sasa

#1792777

Nigel
Supporter

Languages: Anglais (English ) Espagnol (Español )

Timezone: Europe/London (GMT+01:00)

Screenshot 2020-09-28 at 11.00.21.png
Screenshot 2020-09-28 at 10.59.37.png

On my local copy of your site I created a new Listing with some content that I knew meant it should be returned by a particular test search, and then created a new View on a new page to test it, and it worked.

So I returned to look at your View, and noticed that the Query Filter section was missing a filter for the text search input: there is even a warning about that in the editor, see the screenshot.

After clicking that button, a filter for text search field was added (second screenshot).

My test posts didn't match the other filter criteria, but when I removed that other query filter then the text search performed as expected on the front-end, finding the content of the checkboxes fields.

Please try the same on your own site, you should find that it works after updating the query filters.

#1793769

Nigel, thanks, thanks, thanks ... I really appreciate all your help

Thanks, it works 🙂
Sasa

#1793771

My issue is resolved now. Thank you!