Skip Navigation

[Résolu] Javascript error for all WP admin

Ce fil est résolu. Voici une description du problème et la solution proposée.

Problem:
I see this error in the Browser Console:

Uncaught ReferenceError: Toolset is not defined
    at ToolsetCommon.UserEditor.VisualComposerEditor.self.init (backend_editor.js:5)
    at new ToolsetCommon.UserEditor.VisualComposerEditor (backend_editor.js:5)
    at HTMLDocument.<anonymous> (backend_editor.js:5)
    at i (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,utils,jquery-ui-sortable,underscore,backbone,wp-util,&load[]=wp-backbone,media-models,plupload,wp-plupload,mediaelement,wp-mediaelement,media-views&ver=4.8.2:2)
    at Object.fireWith [as resolveWith] (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,utils,jquery-ui-sortable,underscore,backbone,wp-util,&load[]=wp-backbone,media-models,plupload,wp-plupload,mediaelement,wp-mediaelement,media-views&ver=4.8.2:2)
    at Function.ready (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,utils,jquery-ui-sortable,underscore,backbone,wp-util,&load[]=wp-backbone,media-models,plupload,wp-plupload,mediaelement,wp-mediaelement,media-views&ver=4.8.2:2)
    at HTMLDocument.K (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,utils,jquery-ui-sortable,underscore,backbone,wp-util,&load[]=wp-backbone,media-models,plupload,wp-plupload,mediaelement,wp-mediaelement,media-views&ver=4.8.2:2)

Solution:
This is solved in the current Toolset release

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 3 réponses, has 2 voix.

Last updated by morktron Il y a 3 années et 9 mois.

Assigned support staff: Beda.

Auteur
Publications
#582538
Screen Shot 2017-10-27 at 10.40.50 am.png

Hi, I'm getting this javascript error for all pages in WP admin that use JS:

Uncaught ReferenceError: Toolset is not defined
    at ToolsetCommon.UserEditor.VisualComposerEditor.self.init (backend_editor.js:5)
    at new ToolsetCommon.UserEditor.VisualComposerEditor (backend_editor.js:5)
    at HTMLDocument.<anonymous> (backend_editor.js:5)
    at i (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,utils,jquery-ui-sortable,underscore,backbone,wp-util,&load[]=wp-backbone,media-models,plupload,wp-plupload,mediaelement,wp-mediaelement,media-views&ver=4.8.2:2)
    at Object.fireWith [as resolveWith] (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,utils,jquery-ui-sortable,underscore,backbone,wp-util,&load[]=wp-backbone,media-models,plupload,wp-plupload,mediaelement,wp-mediaelement,media-views&ver=4.8.2:2)
    at Function.ready (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,utils,jquery-ui-sortable,underscore,backbone,wp-util,&load[]=wp-backbone,media-models,plupload,wp-plupload,mediaelement,wp-mediaelement,media-views&ver=4.8.2:2)
    at HTMLDocument.K (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,utils,jquery-ui-sortable,underscore,backbone,wp-util,&load[]=wp-backbone,media-models,plupload,wp-plupload,mediaelement,wp-mediaelement,media-views&ver=4.8.2:2)

I found someone is having the same issue here: https://toolset.com/forums/topic/js-error-in-admin-page/ but mine may be different apparently.

This is the file in the error message: .../wp-content/plugins/wp-views/vendor/toolset/toolset-common/user-editors/editor/screen/visual-composer/backend_editor.js

I duplicated the site and disabled Toolset plugin and everything works fine. I'm using the Genesis Theme Framework, however, I don't think it is theme related since I switched to the Twenty Fifteen default theme and the issue remains.

It looks like it is a conflict between WP Bakery's 'Visual Composer' and Toolset because I disabled all plugins except Visual Composer and Toolset and it's only when they are both enabled that the issue occurs.

Ideally, I'd like to remove Visual Composer but that would involve many hours of work, so meanwhile is there a solution? Many thanks

#582596

I think you experience this error?
https://toolset.com/errata/betheme-options-page-is-not-working-when-views-2-5-0-is-activated/

It may be that this happens with other themes as well, for sure the situation requires Visual Composer.
Please can you try that patch and let me know if this solves also your issue?

#582616

Please let me know if that solves your issue?

#582867

Thanks Beda, that has fixed it 🙂