Skip Navigation

[Fermé] I cannot add anymore new custom fields…?

This support ticket is created Il y a 7 années et 10 mois. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Hong_Kong (GMT+08:00)

This topic contains 4 réponses, has 2 voix.

Last updated by Luo Yang Il y a 7 années et 10 mois.

Assigned support staff: Luo Yang.

Auteur
Publications
#293376

I am trying to: Add another checkbox custom field under my Group called "Reviews."

I visited this URL: My "Edit Group" page.

I expected to see: I added custom field to this page just as I have done with my other 45 custom fields.

Instead, I got: The new custom field will show up in the Edit Groups page after I add it and click save, but it will then disappear when I go back to the Edit Groups page. It also does not show up as an option to fill in on my Custom Post Type. All of the other custom fields work fine, but I cannot add a new custom field for some reason.

Solutions I have tried:

1) I checked for a corrupt .htaccess file. It was not corrupt.
2) I tried deleting the one I created, and make a new one, but that did not work.
3) I downloaded the wp-views plugin files again and uploaded them to my site via FTP. This did not fix the problem.
4) Added function to my functions.php to increase allowable custom fields to be 100 (just in case a limit was the issue)

#293382

And another thing I just noticed...

Normally when I would update the custom fields on the "Edit Group' page and click "Save" the refreshed page would display a banner up top saying that it was saved.

However, now, this sort of confirmation is not present when I reach this page after saving.

#293387

I just learned that I also cannot edit my current custom fields in the Group Editor page either.

#293470

Hello?

#293617

Luo Yang
Supporter

Languages: Anglais (English ) Chinois simplifié (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Dear Daniel,

Are you using Types plugin to setup the custom fields?
Please check this:
1) your custom fields is setup by following our document:
Adding WordPress Custom Fields to Content
https://toolset.com/documentation/user-guides/using-custom-fields/

2) if above doesn't work, please try deactivate other plugins and switch to wordpress default theme, and test again.

3) enable wordpress debug mode, repeat the actions you mentioned above, and post the debug logs here.
https://toolset.com/documentation/user-guides/debugging-types-and-views/

PHP Debugging

In case you think that Types or Views are doing something wrong (what we call a bug), you should enable PHP error logging. Again, edit your wp-config.php file and add the following:

ini_set('log_errors',TRUE);
ini_set('error_reporting', E_ALL);
ini_set('error_log', dirname(__FILE__) . '/error_log.txt');
This will produce a file called ‘error_log.txt’ in your WordPress root directory. Make sure that the web server can create and write this file. If it cannot, use an FTP program to create the file and make it writable to Apache (normally, user www-data).

Le sujet ‘[Fermé] I cannot add anymore new custom fields…?’ est fermé à de nouvelles réponses.