Skip Navigation

[Résolu] Google map not displaying on the front end

Ce fil est résolu. Voici une description du problème et la solution proposée.

Problem: I have a Google Map placed on my site but it does not appear on the front-end.

Solution: Make sure you have used the correct map ID in your shortcodes.

Relevant Documentation: https://toolset.com/documentation/user-guides/display-on-google-maps/

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 2 réponses, has 2 voix.

Last updated by Tom Gonzales Il y a 3 années et 5 mois.

Assigned support staff: Christian Cox.

Auteur
Publications
#612844

I am trying to: add a new custom post section that includes a Google Map in the Custom View, but the map is not displaying on the frontend. It does display in the post edit mode, and this same code works fine on another site. Plus the same Google Map feature works fine in other sections. (See these link for example of other section where Google Maps works fine) hidden link

I've already checked for plugin compatibility issues, generated a new Google Maps API Key, and I've created a Duplicator package and Toolset Support admin account and will share the download location in a private message when you provide me a link to do so.

Link to a page where the issue can be seen: hidden link

I expected to see: hidden link

Instead, I got: World map

#612988

Christian Cox
Supporter

Languages: Anglais (English )

Timezone: America/New_York (GMT-04:00)

Hi, I'll be glad to take a look. Please try these troubleshooting steps first:
- Go to Toolset > Settings > Maps and check the Cached Data information. If you see an address that corresponds to the address field in this post, delete it then retest: /kids-camp/envision-national-youth-leadership-forum-pathways-to-stem-university-of-texas/
- Temporarily activate a default theme like Twenty Seventeen and deactivate all plugins except Types, Views, and Maps. If you need to activate a plugin like Maintenance Mode during testing, that's fine.
- If the marker begins to show up, reactivate your theme and plugins one by one until the conflict is revealed.
- If the marker is still hidden, please use the private reply fields to send me a download link to your Duplicator package. I'll review the configurations and give you some feedback.

#613104

Thanks for your help, but I figured it out. I was using the wrong Map ID.