Skip Navigation

[Résolu] Floating social bar does not display properly on content templates

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 11 réponses, has 3 voix.

Last updated by nthulaneM Il y a 6 années et 6 mois.

Assigned support staff: Caridad.

Screen Shot 2015-04-15 at 11.57.22 AM.png
Screen Shot 2015-04-20 at 12.25.41 AM.png
Screen Shot 2015-04-15 at 11.58.29 AM.png

Good Day,

I have installed a Floating Social Bar Plugin on my website but it does not display properly in my content template but it does show properly in my blog post. The floating social bar changes the structure of the content template.

hidden link

The images should tell the story. Please assist



Languages: Anglais (English )

Timezone: Asia/Karachi (GMT+05:00)

I have tried visiting different pages of your website (including blog). Can you please point out some specific URLs to understand the issue?


When you setup the plugin you can switch off certain pages, I have switched off the pages on which it doesn't appear properly on because it will mess up the website. The screen shots show it looks though.

You might need to move the website to your local environment, switch it on for those pages in order to see what I mean. Thoughts?



Languages: Anglais (English )

Timezone: Asia/Karachi (GMT+05:00)

I understand your point, can you please setup a test site (on a subdomain or wherever possible) and provide an access? So I can look into the issue and can try a fix (or report accordingly).

I have set your next reply as private, please input all details in that area, thanks.



Languages: Anglais (English )

Timezone: Asia/Karachi (GMT+05:00)

Thank you for providing the access. Please allow me some time to look into the matter. I will update you as soon as I find a solution.

Thank you for your cooperation and patience. I will try my best to keep website users less surprised 🙂



Languages: Anglais (English )

Timezone: Asia/Karachi (GMT+05:00)

I have observed the issue, and have turned off the FSB for said pages. However, I have created a post "Test FSP Post" and a content template to use with single post pages. I am using this only for Test FSB Post, rest of the posts are not affected.

On this post I did some experiments and found that Views short codes (related to content output, like title, body, excerpt, featured image and etc) are some how filtered through the WP standard content filtering API. And there's the problem. Because FSB injects the social bar at the same event.

Practically, whenever that particular content filteration occurs, FSB does it's job. I think this is more of a compatibility issue. I am not sure if our Team will opt-in to provide a compatibility, or FSB guys may provide a solution. But I will try to find a way in between.

I am referring the issue to the relevant Dev Team for an expert opinion and/or solution. I will update you as soon as I hear back.



Languages: Anglais (English )

Timezone: Asia/Karachi (GMT+05:00)

Please see the issue fixed on your site. The Dev Team used an attribute suppress_filters="true" to the [wpv-post-body] short code (

They also suggest to upgrade to latest version of Views (1.8).

I hope the matter is resolved.

Screen Shot 2015-05-04 at 7.59.45 PM.png

I don't understand who the matter is resolved because the social bar still displays everywhere on a Toolset generated content template. I have updated everything that needed to be updated.

Please help.


Your plugin is appending the social bar when the filter "the_content" is used.

This filter is normally called after displaying a post, but its also being called after displaying a Content Template or View. Thats why you are seeing it everywhere.

To avoid this you can either:

1) turn off automatic appending of the social bar and include it only where you want to (in the corresponding Content Template).

2) Or you can use the wpv-post-body with the suppress_filters="true" argument.

These are the only 2 ways to avoid the duplication of social bars.

I have access details, if you want you can point me to a social bar that you need to remove and I will look into it.


You've given me 3 options and i don't know how to go about all 3 of them. I think i have an idea of the 3rd option the most.

Please log in to my admin area. Settings --> Floating Social Bar, you will see that its only activated for posts but I would like to activate it for Organisations, Supports Appliable, Funders Appliable, funders and supports. These others are not activated because of the duplication.

Please look into it.


I gave you 2 different options instead of 3.
Let me go into more detail:

1) The first option means to leave the setting disabled and display the bar using the shortcode available in the Content Template:


Taken from:

I have edited your "Supports Appliable Template" Content Template so you can see this working.

2) The second option is to avoid the WYSIWYG fields to call the 'the_content' filter which is used for automatically adding the social bar.

To do this, I enabled the setting for "Organizations" and made the appropriate changes to the "Individual Organisation" Content Template by adding suppress_filters everywhere there is a duplicate bar.

[types field="about" suppress_filters="true"][/types]

You will see that both solutions work.



When I said 3, I meant that you doing it for me was the 3rd option.

You're either very good or i'm slow, either way, thanks for your assistance.