Skip Navigation

[Résolu] Editing form redirects to 404 after submit

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 19 réponses, has 2 voix.

Last updated by Minesh Il y a 2 années et 3 mois.

Assigned support staff: Minesh.

Auteur
Publications
#1155312

PZ

On this site hidden link to which I gave you full access you can do whatever you want.

#1156337

Minesh
Supporter

Languages: Anglais (English )

Timezone: Asia/Kolkata (GMT+05:30)

Well - this is a really strange issue.

I've reported it to our next level support for the further debut. Please hold on for further updates.

#1157322

PZ

Ok, thank you. When can I expect any reply? It is quite urgent as the site's users cant edit their posts.

#1157546

Minesh
Supporter

Languages: Anglais (English )

Timezone: Asia/Kolkata (GMT+05:30)

Ok - I will report this in front of our next level support. Please hold on for further updates. We are actually loaded at this end but I will try to add your voice to our internal ticket.

#1190306

Minesh
Supporter

Languages: Anglais (English )

Timezone: Asia/Kolkata (GMT+05:30)

I've update for you.

We found the issue in Toolset > Post Types > Firmy > Options > Rewrite > Use a custom URL format. There, you inserted /.
Please check the following screenshot: hidden link

If you instead use "Use the normal WordPress URL logic" then all works fine. Note, if of course also works fine if you rewrite the URL, but you need to use something else than /, for example, a string, to be prepended.

The reason it works for some posts but not others is that the user uses cache and old permalinks are stored for the posts that work, but not for those which do not.

So instead of using /, you should use a slug/string.