Skip Navigation

[Résolu] DIVI- Content Template for Single CPT- Option to remove the container class wrap

This support ticket is created Il y a 5 années et 1 mois. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

No supporters are available to work today on Toolset forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

Sun Mon Tue Wed Thu Fri Sat
- 7:00 – 14:00 7:00 – 14:00 7:00 – 14:00 7:00 – 14:00 7:00 – 14:00 -
- 15:00 – 16:00 15:00 – 16:00 15:00 – 16:00 15:00 – 16:00 15:00 – 16:00 -

Supporter timezone: Europe/London (GMT+00:00)

Marqué : 

This topic contains 1 réponse, has 2 voix.

Last updated by Nigel Il y a 5 années et 1 mois.

Assisted by: Nigel.


When assigning a certain content template to a single CPT, pls add the option to remove the 'container' wrapped around the post content. Similar to what toolset already implemented for WC Product CPT -> "Add a container DIV around the post body for WooCommerce styling".

Instead of css overriding hack to make it full width, the option to remove/add a container DIV makes things less messy.

related question then ->



Languages: Anglais (English ) Espagnol (Español )

Timezone: Europe/London (GMT+00:00)

Hi there

Views Content Templates don't add a wrapper div, they just output whatever is in the template directly. Whatever "wrapper" you find on the content comes from the theme. (That is easier to see when you are not using Divi—which adds *lots* of nested divs—and just add a simple Content Template with twentyseventeen, for example.)

If you are having problems with full-width content with Divi, note the recommendations here:

In particular, the section Additionally, within the Row Settings set a custom width of “100%”. Do not select “Full-width row” because, despite the name, it sets the row width to “89%”.

This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.