Skip Navigation

[Résolu] Displaying CPT Archive within an Oxygen Builder Template

This support ticket is created Il y a 4 années et 4 mois. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

No supporters are available to work today on Toolset forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

Sun Mon Tue Wed Thu Fri Sat
- - 14:00 – 20:00 14:00 – 20:00 14:00 – 20:00 14:00 – 20:00 14:00 – 20:00
- - - - - - -

Supporter timezone: Asia/Ho_Chi_Minh (GMT+07:00)

Marqué : 

This topic contains 10 réponses, has 2 voix.

Last updated by Beda Il y a 4 années et 3 mois.

Assisted by: Beda.


I am using Oxygen Builder and Toolset.
I have a CPT for "Documents" which I am displaying in a View, within a Page template designed within Oxygen Builder.
The View includes links to archive pages for Categories and Taxonomies, and other custom fields such as Document Type and Intented Audience.
I have styled the Archive View within Toolset, and created a template within Oxygen Builder that applies to all Archive pages.
However, when I click on an archive link in the main View, it does not display the archive view, but instead displays a single post view, the first post in the archive loop.

I appreciate that this query should be pitched to the Oxygen support folks too, but I thought I would start here.

Is there a "proper" way to display Category and Tag archive pages within Oxygen Templates, from the links created within a standard View Loop?



Oxygen Builder is integrated in Toolset, in some points, as seen here:
hidden link

You cannot create Archives, however:

You can of course use Toolset (but no oxygen builder) for archives:

Basically, you should not mix Oxygen and Toolset on archives.

Can I ask:
1. However, when I click on an archive link in the main View, it does not display the archive view but instead displays a single post view, the first post in the archive loop.

This archive link, where exactly does it lead? If the URL it leads to is correct then we can forget about this View, as it just produces the link.
If the URL is not correct, then we can forget about the Archive, as then the issue would be the URL.
In any case, I do not suspect issues with the archive, I suspect issues with the ShortCode creating links to it.

Maybe you can send me a copy of this site or a precise step by step instruction how I can replicate it and then I could debug this as well as eventually report it to the adequate developers if needed?



Hi Beda,

Thanks for your input on this.
I tried creating a duplicator package but this is only a test site on cheap shared hosting and it keeps timing out.
I'm happy to share admin login details with you, if that's useful?

The archive links are in relation to tags and categories, and so for example, you can see in this screenshot I have annotated in red text where the links point to: hidden link

I've read other threads about the difficulties with archive views within Oxygen, so I'm hoping there is a decent workaround?



I can look at it online, can you send a link where the issue is visible, and a description of where what is edited?

I'll enable a private reply.


I see on hidden link that the View "Document View (BS3)" is deployed there, and its links to the respective Taxonomy Archives of "Tagged in" seem to link to the proper URLs.

In all of those links cases you'd be directed to the Tag archive, something like hidden link, or also:
hidden link

That is an archive, and cannot be styled using Oxygen, as the DOC elaborates which I shared previously:

Those archives, need to be (if) styled with Toolset > WordPress Archives only.
When I click on any of the tag links, which do correctly lead to the archive in question, I'm lead to the archive, not a single post.
For example hidden link, or any other, this is an archive.
It is styled in hidden link, the "Documents archive".
And that Archives's loop item is exactly what's seen on the front end, you can confirm that by adding a "TEST STRING" to the archive, it'll be visible on archives like hidden link, if added to hidden link Loop item.

That Loop Item can no be edited with Oxygen, officially, as you cannot style archives with Oxygen and Toolset, only with Toolset.

I hope with this information it's easy for you to proceed.


Hi Beda,

Thanks for taking a look at this.
It's OK that I can't style the archive itself in Oxygen. I'm happy to create the archive template within Toolset.

I can see that the tag and category links do indeed point to the archive, however, I don't think the archive is displaying the correct posts.
You give an example of the tag "funding" - hidden link
There is only one post tagged with funding - so when we click the link to that particular tag archive, should it only display that one post? Instead, we see several of the "Documents" custom posts and there are also PAGES listed in the archive, e.g. the My Account page. There are also some strange entries, e.g. "Organisations Documents: 440 - 438" - there is no post with this name, so I'm not sure where this data is coming from. EDIT: I've realised this is linked to a Relationship I set up (Organisations is a separate CPT, and linked to Documents via a Relationship).



The archive hidden link is set to apply on Tags, Categories and the Post Type "Documents".
So on all those 3 archives, the same will apply.

If we visit a Tags archive, the Archive will display only "Document" posts in that archive (documents, tagged with the term we currently see).
That's what the settings say at hidden link

But since the archive also has a View inserted (Document Search View, hidden link), you see that output as well.
That View, returns most Documents, no matter what, until you search and filter.

I'm not entirely sure where you insert this View, as it's not added to the Toolset WordPress Archive, so maybe you added it to some header or archive template in the oxygen builder?


Hi Beda,

Apologies, I had been experimenting with a different search template.

There is an Oxygen Template called Default Archives, which is set to apply to all Archive pages.
I have changed this template to show dynamic data > Toolset View > Documents Archive.
(For testing, I have edited the Document Archive to show a text string "This is the Documents Archive" within each item in the loop)

However, there are two issues as far as I can tell:

1) it is still showing a long list of Documents including many which DO NOT BELONG to the particular tag or category that the URL relates to.
2) It is also showing some entries which I think are linked to Relationships, e.g. "Organisations Documents: 482 - 480"
(There is another CPT called Organisations, linked to Documents via a relationship - but not sure why these are showing up in the Archive??)

Grateful for your support.


Thank you for the additional details.

In this case, you are styling the archive with an Oxygen Template 🙂
But we agreed that this is not possible, together with Toolset:

Now, it seems that Oxygen went as well into Archive integration, as you mention you could choose "Toolset View > Documents Archive" in the Oxygen Archive settings.

I also agree the archive is shown, see (Test string added).
But A) There are other Views loaded and B) Something (presumably now Oxygen) is overwriting the Archive loop.
This then can lead to the 2 issues you mention.

I am not familiar with Oxygen's integration for Toolset Archives, but I know their Developers did very nice work in other integrations related to Toolset.
I also do not see any mention of Archives here hidden link.
Are you sure that Oxygen is supposed to "support" Toolset Archives, and that it is not a BUG (being able to set a Toolset Archive as dynamic output)?
Do you know of any documentation that explains this process?

It would be important to reconstruct this and check if it still happens on a clean install.

For now, I can only ask to test this:
- remove any Oxygen assignment from archives if you want to style those archives with Toolset Views.
- Design the Archives with Toolset > WordPress Archives
- If it's then still not working, make sure, to not include any other Views in that Archive (for testing)

We can still proceed to work on the issue itself after, for example with details as above mentioned I could replicate it locally if you can instruct me how to or/and according to some Documentation.


Thank you Beda, I am still trying to work through your suggestions, but thought I would share that I have also contacted the support folks at Oxygen, and this is what they had to say:

"there's something wrong with the way the View retrieves posts using the default query. To test this, we added an Easy Posts element with the default query to the archive template. You can see here that it's retrieving the correct posts: hidden link.

We'd suggest that you contact Toolset to see if they can identify why the View is failing to use the default query on the taxonomy archive. It may be that there's an additional setting needed when using the View with Oxygen."

I don't know if this helps at all?



I don't understand.

The case that you report is a View, in an Archive, styled by WPA (WordPress archive of Toolset) AND Oxygen (not supported), and nothing's broken or lost after all:
The View which is nested into the archive still outputs the loop, but the loop of the archive is overwritten.

Bottom line, on archives, you cannot use Oxygen if Toolset is used on them. If you can, then there must be a Documentation or so that states this, on our end we state yo can't, and that's because we saw it is not integrated.

Hence I am not sure how the example made relates to our issue.
What is "Easy Posts"? And what is a "Standard Query"?
Views have no standard query, it uses the WordPress WP Query, to build queries and return results that you can find in the database with the WP Query.
What would be closest to a "default" search here would be a View, filtered by a Text Search field, but that's not the case.

Hence I am little confused on that example, and think it's better we proceed with what we know:
1. Oxygen and Toolset on archives together are, on our end, not supported.
I am of course ready to dive in if this is somehow supported on the Oxygen end, but I'd need some guidelines suggested for testing.
2. As long that is not supported, you should not use Oxygen on those archives, and as soon that is not the case, I understand the issue is resolved, is this correct?

If not, please do not hesitate to update me 🙂

This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.