Skip Navigation

[Résolu] Display error single fields inside conditional blockdd

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 25 réponses, has 2 voix.

Last updated by hansooH Il y a 1 an et 5 mois.

Assigned support staff: Christian Cox.

Auteur
Publications
#1647381

This is bad news for us.
I made a first field on the conditional block. It shows all right.
However, I made next few fields on the conditional block. It shows short code again.

I made a test site for you
hidden link
id / ps are all same.

Sorry about that. Please Please help me again.

#1647813

Hello, thanks for the additional troubleshooting information for this shortcode issue. I am downloading the Duplicator now, and I will give you an update after I run some additional tests on my local environment...please stand by.

#1647925
Screen Shot 2020-06-02 at 11.38.22 AM.png

After installing the Duplicator clone on my local site, I have been unable to reproduce the problem so far. I'm attaching a screenshot here so you can see the local results. The conditional is in place, and all the shortcodes seem to be rendered as expected. This is curious, so I visited the test site to get more details about the problem. The Content Template on the test site only had one shortcode inside the conditional - the company phone number. I was not able to see the problem. So I tried to add a few more fields to reproduce the error, but the site became unresponsive and now I neither load nor edit this Leader Manager post:
hidden link

Nor can I edit this Content Template:
hidden link

After several minutes, I get a 502 gateway error from nginx. Can you check to see what might be happening? If possible, we should check the server logs to see what could be happening on the server, why everything is so slow, and why we cannot edit this post or this template. If you are not familiar with server logs, I can show you how to activate them temporarily. Go in your wp-config.php file and look for

define('WP_DEBUG', false);

Change it to:

define('WP_DEBUG', true);

Then add these lines, just after the WP_DEBUG line:

define('WP_DEBUG_LOG', dirname(__FILE__) . 'https://cdn.toolset.com/error_log.txt');
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );
define('WP_DISABLE_FATAL_ERROR_HANDLER',true);

Try to edit the Content Template or the Leader Manager post again. If any server-side errors are triggered during this process, it will create an error_log.txt file in your site's root directory. Use FTP to look for the error_log.txt file, usually in the same directory as wp-config.php. You may need to click "Refresh" in your FTP browser to see a new file appear. Please download this file to your computer, open it in any text editing software, and send me its contents. Once that is done, you can revert the changes you made to wp-config.php and delete the log file using FTP.

#1648505

Thank you for your help. I used All-In-One WP Migration plug-in for migration. In this case I think the plug-in made a some trouble. I reinstall test.fcakorea.org and tested test.fcakorea.org has no speed problem. Also I will fresh install wp and toolset plug at "new.fcakorea.org" and I will test this problem on new site. then I will give you result after testing. Thanks again.

#1648671

I tested new.fcakorea.org. but it has same problem. My server is using Wordops, php7.4 nginx redis-cache. How about your server configration? Does you use apache? I can test with apache server. What do you thing testing on apache server?

#1648675

I create new content template for leader manager on new.fcakorea.org It is successfully rendered fields. (I create 4 fields)
I think old content template (I created the first time) has some problem. I will continue testing with new content template.

#1649255

Okay, yes I use Apache on my local test environment. If the new template continues to have trouble please let me know and I can take a closer look.

#1653763

I'm sorry late reply. I'll have to do a little more on my newly installed WordPress test, but so far it looks fine. Thank you so much for your help. I will let you know if there are any problems as we continue to develop. Thank you.

#1662691

I found the problem.
An error occurred when the row in the conditional logic exceeded 5 rows.
I tested it on a faster server, so 7 rows was fine.
So, if you increase the waiting time for the response time value in Toolset code, I think this problem will be solved.

I fixed this problem to create the same conditional logic in one page to store only 5 rows of field values each, and now I confirmed that all displayed normally.

#1663353

Thanks for the additional information. Since it is related to the length of a conditional, you could be running into this issue:
https://toolset.com/errata/shortcodes-in-conditionally-displayed-content-may-not-be-executed-on-the-front-end/

#1663551

Thanks Christian, This is very important information for me. 🙂