Skip Navigation

[Résolu] Custom type field entries won't save any more

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 24 réponses, has 3 voix.

Last updated by filipV-3 Il y a 4 années et 1 mois.

Assigned support staff: Minesh.

Auteur
Publications
#554754

Minesh
Supporter

Languages: Anglais (English )

Timezone: Asia/Kolkata (GMT+05:30)

Thank you for sharing duplicator package.

Well - the line causing the issue with your theme is which is added within "wpse_comment_form" shortcode in your current theme's functions.php file:

print(  '<style>.no-comments { display: none; }</style>' );

If you comment out the above line then the page loads successfully. This is not the way to add inline CSS using WordPress. To add inline CSS:
=> https://codex.wordpress.org/Function_Reference/wp_add_inline_style
=> https://wordpress.stackexchange.com/questions/104657/how-to-add-dynamic-inline-style
=> https://wordpress.stackexchange.com/questions/168867/using-wp-add-inline-style-without-a-stylesheet

Regarding field not saving, I can see that when I edit any profile its saving the checkboxes and radio button states and for other fields it saves the field value successfully. If you have still issues it will be great if you can share any specific profile edit link and few field names which are those which you are not able to save in backend.

#555126

hi Minesh,
yes the loading works after i commented that out, thank you!

The saving still doesn't work however. Example:
profile: /profile/clara/
what i did fill: an address in 'field group 1 - personal data' so that map shows up + a little text justr below in 'introduce yourself' + just below there at 'field group 2 - contact': the obligatory fields 'repond to hidden numbers' and 'sms'.
By saving it says the page is saved but nothing was really saved at all.

#555140

Minesh
Supporter

Languages: Anglais (English )

Timezone: Asia/Kolkata (GMT+05:30)

Well - I tried to edit the exact profile and tried to save the fields and its successfully saved.
=> hidden link

And I can also see in effect on frontend.
=> hidden link

#555180

Hi Minesh, i see.... Is this even logically possible? ???? Perhaps browser related, i worked with Firefox and will test with your browser (which is?)
Or can you think of another reason perhaps?

However in that profile, in admin, i get this error message after opening the profile:
We could not connect to the Google Maps autocomplete service, but you can add an address manually.
First time i get this one.

Thanks a lot!

#555186

Minesh
Supporter

Languages: Anglais (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Minesh, i see.... Is this even logically possible? ???? Perhaps browser related, i worked with Firefox and will test with your browser (which is?)
Or can you think of another reason perhaps?
=> Well - I'm on windows platform and using Chrome browser. I do not able to reproduce the issue which you are saying as its working for me both on local and on your site.

May be if you have any chache plugins or using cache please try to delete cache and try to check with different browser.

However i that profile, in admin, i get this error message after opening the profile:
We could not connect to the Google Maps autocomplete service, but you can add an address manually.
First time i get this one.
==> Today we have published the new version of ALL Toolset plugins, so I request you to update ALL Toolset plugins to it's laltest official release version and then to minimize the cause of the issue try to disable pluings one by one and check with the default theme. I suspect your theme is outdated here and thats causing the issue.

#555205

Hi Minesh,
i updated the plugins, i tested again with 2017 theme and no other plugins, i tested via Chrome, there is no cache, ...
and it still doesn't save 😮

I don't understand...

#555206

Minesh
Supporter

Languages: Anglais (English )

Timezone: Asia/Kolkata (GMT+05:30)

I really do like to help you further but I'm helpless as I do not able to reproduce the issue on your test site (I already show you by updating the profile on your site) as well as I do not able to reproduce the issue on my local site using duplicator package you provided.

#555221

Well i just tried with your login, and it works for me... :/
Both logins are administrator, no special differences afaik, but sure there must be something. I'll research the whole setup A-Z and let you know if I find anything.
Thank you Minesh!

#555222

Minesh
Supporter

Languages: Anglais (English )

Timezone: Asia/Kolkata (GMT+05:30)

Great - happy to see that you have spotted the issue and it was not with my login and I was right 🙂

Also, as this ticket has already become the thread, could you please mark this resolved and open a new ticket when you find the issue and relate this old ticket when you open a new ticket. This will help other users searching on the forum.

Thank you for your understanding and have a great day ahead.

#555232

sure, closed!