Skip Navigation

[Résolu] Custom type field entries won't save any more

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 24 réponses, has 3 voix.

Last updated by filipV-3 Il y a 4 années et 1 mois.

Assigned support staff: Minesh.

Auteur
Publications
#548902

hi Luo,
so issue 2 is: the entries in my custom post type 'profiles' don't save any more anything. Can't edit the post fields. When i click update the page, it behaves normally, but the edits aren't saved.
I reported this same issue over 6 months ago, it was just one specific post type that wouldn't save back then, but now it's like a general problem. I have now 9 post field groups there in profiles, and will connect them to CRED once they start working normally again.

Please provide a private reply for my data, thanks!!

#549330

Luo Yang
Supporter

Languages: Anglais (English ) Chinois simplifié (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Dear filip,

The problem you mentioned above is abnormal, we need to know if there is any compatibility problem in your website, please check these in your website:
1) you are using the latest version of Toolset plugins
2) deactivate other plugins and switch to wordpress default theme, and test again

If the problem still persists, please provide a database dump file of your website in below "private detail box", also point out the problem page URL, and where and how I can see the problem, I need to duplicate same problem and debug it in my localhost, thanks

#549671

Luo Yang
Supporter

Languages: Anglais (English ) Chinois simplifié (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

I can not find the "datadump" in your post:
https://toolset.com/forums/topic/custom-type-field-entries-wont-save-any-more/#post-549650

Please check it, thanks

#549850

it says that the sql file extension is not supported?

#550196

Luo Yang
Supporter

Languages: Anglais (English ) Chinois simplifié (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

You can put the database dump file into your own website, and provide a downloadable URL for it.

#550325

i need a private reply for that please

Isn't it possible to assign this to somebody else, Luo? Somebody who closer to European time-zones. It's already 5 (five!) days that i reported the problem, and we're not even so far that somebody's able to look at it.
A system to send db which can't handle database extensions and such, private messages only on demand, and such, no wonder this issue is going on for a year already and it's not being solved. I was supposed to be on holidays already but i'm sitting here waiting for a one reply a day-thing. Nothing personal at all, but this is going nowhere like this. Thanks a lot!

#550596

Luo Yang
Supporter

Languages: Anglais (English ) Chinois simplifié (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

OK, I have enabled the "private detail box" again, please provide a downloadable URL of your database dump file.

And if I can not answer it today, I will reassign this thread to other supporters who is closer to European time-zones.

#550790

Minesh
Supporter

Languages: Anglais (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello filipV-3,

Luo passed me this ticket and I'll take care of this ticket.

Before I proceed to check anything - could you please try basic debug steps:
1)
Could you please activate WP_DEBUG from wp-config.php file and send me possible errors for review.

2)
If #1 does not help, could you please send me temporary access details and exact steps to reproduce the issue.

*** Please make a FULL BACKUP of your database and website.***
I would also eventually need to request temporary access (WP-Admin and FTP) to your site. Preferably to a test site where the problem has been replicated if possible in order to be of better help and check if some configurations might need to be changed.

I would additionally need your permission to de- and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important. If you agree to this, please use the form fields I have enabled below to provide temporary access details (wp-admin and FTP).

I have set the next reply to private which means only you and I have access to it.

#551389

Minesh
Supporter

Languages: Anglais (English )

Timezone: Asia/Kolkata (GMT+05:30)

Well - it looks like issue with your wp-admin memory and max input vars.

1)
Could you please increase value of PHP setting for "max_input_vars" to 3000.
http://stackoverflow.com/questions/10303714/php-max-input-vars
-- Please contact your server admin to update above setting.

2)
Could you please try to increase memory limit for wp-admin and check your issue. Please try to add following lines to wp-config.php file.

define( 'WP_MAX_MEMORY_LIMIT', '512M' );

Please refer to the following link that may help you:
=> http://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

if #1 and #2 does not help, could you please check your server log and check what errors you see there.

#552107

Hi Minesh,

sorry for the late reply due to the weekend.
We have our own managed VPS; memory 512 is default. We changed max input vars from 1000 to 3000 but it doesn't solve the issue.
Will try to get that server log, best as private reply probably?
PS i just found another error: there are a few test profiles placed, but only our main reference profile (i sent link in last private reply) can actually be fully seen. All other profiles generate a blank page... Perhaps the issues are related and couldn't it be that the server settings aren't? (cause in no other web on this vps where we use the same toolset techniques, we have this issue)

Thank you!

#552585

Minesh
Supporter

Languages: Anglais (English )

Timezone: Asia/Kolkata (GMT+05:30)

Could you please share the profile link which is not working.

#553090

Minesh
Supporter

Languages: Anglais (English )

Timezone: Asia/Kolkata (GMT+05:30)

Well - I changed the theme to 2016 and I see that this page is loaded.
=> hidden link

So - could you please check you see the fields with 2016 theme.
=> If it still not displays - could you please check with your database that if custom fields values are there with post meta table for each post.

#553149

Hi Minesh,
you're right, it shows with 2016, strange and not good news (for me). Bizarre that one profile does show and the others not, there's no difference between them at all....

So let's than concentrate on the not-saving of those fields in the profiles... The theme doesn't influence this and neither do the plugins, while server settings are correct...

Thanks a lot!

#553387

Minesh
Supporter

Languages: Anglais (English )

Timezone: Asia/Kolkata (GMT+05:30)

Could you please share your site copy with me using duplicator package:
=> https://toolset.com/faq/provide-supporters-copy-site/

I have set the next reply to private which means only you and I have access to it.

#553388

Minesh
Supporter

Languages: Anglais (English )

Timezone: Asia/Kolkata (GMT+05:30)

It looks like on profile edit page it saves the field now.

I've added following line of code to wp-config.php file:

define('WP_MAX_MEMORY_LIMIT', '512M');

And I've tried to save the field value "Introduction" at bottom of the page and I can see the value is saved successfully. Could you please confirm.