Skip Navigation

[Résolu] Custom taxonomies not showing in Add menu items

Ce fil est résolu. Voici une description du problème et la solution proposée.

Problem: The user would like to use taxonomy terms in menus, but he cannot find them.

Solution: The taxonomy terms are supported by WordPress menus. They may be hidden by the screen options. Check this screenshot.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 2 réponses, has 2 voix.

Last updated by joshM-4 Il y a 1 an et 6 mois.

Assigned support staff: Jamal.

Auteur
Publications
#1573571
Screen Shot 2020-04-03 at 12.30.13 PM.jpg

I am trying to: Add items from a custom taxonomy to a WordPress menu.

I have a custom post type, Products. It has 2 custom taxonomies (Magnetic Functions and Mechanical Functions). When I build a menu, neither are available. In both of these taxonomies, I have "show_in_nav_menus" enabled. I have also tested this with all plugins except for toolset disabled, and with both the default 2019 and 2020 themes. Nothing fixes it.

I have attached a screenshot.

#1574207

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello and thank you for contacting the Toolset support.

Maybe the custom taxonomies are just not selected on the options of the menu. Check this screenshot to open screen options and select the taxonomies if they are omitted. hidden link

If it does not help, I might need to access your admin area or take a copy of your website for further debugging.

#1574233

Wow, a little embarrassed I didn't think to look there first... thanks for the help. That was the issue.