Skip Navigation

[Résolu] Custom Field Group not appearing in "Fields and Views" for Content Template

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 2 réponses, has 2 voix.

Last updated by Eric Il y a 6 années et 3 mois.

Assigned support staff: Luo Yang.

Auteur
Publications
#313896
Screen Shot 2015-06-29 at 6.09.31 PM.png
Screen Shot 2015-06-29 at 6.09.44 PM.png

I have a custom field group called "Webinars Extras." It has two custom fields in it. I've linked it to my "Webinars" custom post type, and can see those custom fields in the post editor, and add data to them. So far so good.

I created a Content Template called "Webinar Single." When I click the "Fields and Views" button to add content to the template, I don't see the "Webinar Extras" custom field group. I can add fields manually, like so:

[types field="webinar-url"][/types]

...but shouldn't that custom field group be visible to the content template?

#313928

Luo Yang
Supporter

Languages: Anglais (English ) Chinois simplifié (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Dear Eric,

It is abnormal, could you try this:
1) upgrade Types plugin to the latest version 1.7.3, you can download it here:
https://toolset.com/account/downloads/
2) deactivate other plugins and switch to wordpress default theme,
3) enable wordpress debug mode, repeat the actions you mentioned above, and post the debug logs here.
https://toolset.com/documentation/user-guides/debugging-types-and-views/

#314037

Upgrading Types solved it. I wonder why there was no notice in WP Admin Plugins or Updates to update the Types plugin. As far as I knew it was the latest. At any rate, problem solved.
Thanks,
Eric