Skip Navigation

[Résolu] CRED « There was an error while submitting the form » YOAST

Ce fil est résolu. Voici une description du problème et la solution proposée.

Problem:

I have this error being thrown "There was an error while submitting the form" but only when Yoast is activated.

Solution:

It seems to be a compatibility problem, please try to disable the AJAX submit form, like this:

Edit the post form, in section "Other settings", disable option "AJAX submission", save it, and test again.

Relevant Documentation:

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 7 réponses, has 2 voix.

Last updated by jasonw-2 Il y a 3 années.

Assigned support staff: Luo Yang.

Auteur
Publications
#1083190

I have this error being thrown "There was an error while submitting the form" but only when Yoast is activated.

Lastest version of WordPress.
All Plugins up to date.

You will have to scroll to the justgo folder to get in via the ftp credentials.

#1083203
edit.jpg

I could give more information to make your life easier but there isn't any way to 'hide' it. Just like when it asks which site this is for and I have to put 'under dev' so everybody on here can't see my sites. 🙂

Thank you for all you do. Your support is the best I've ever seen!!

JW

#1083634

Luo Yang
Supporter

Languages: Anglais (English ) Chinois simplifié (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Hello,

1) Deactivate other plugins, and switch to wordpress default theme 2017

2) Enable PHP Debugging
https://toolset.com/documentation/programmer-reference/debugging-sites-built-with-toolset/#php-debugging

3) Test the Toolset form again, copy/paste the debug logs here

4) If the problem still persists, please provide database dump file(ZIP file) of your website, also point out the problem page URL and view URL, I need to test and debug it in my localhost, thanks
https://toolset.com/faq/provide-supporters-copy-site/

#1084777
#1085404

Luo Yang
Supporter

Languages: Anglais (English ) Chinois simplifié (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Since it is a compatibility problem, please provide a copy of your website, you can put the duplicator package in your own google drive disk, and share the link in below private message box, I need to test and debug it in my localhost, thanks
https://toolset.com/faq/provide-supporters-copy-site/

#1087593
#1088190

Luo Yang
Supporter

Languages: Anglais (English ) Chinois simplifié (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Thanks for the details, I am downloading the file, will feedback if there is anything found

#1088197

I'll be here..

#1088234

Luo Yang
Supporter

Languages: Anglais (English ) Chinois simplifié (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

It seems to be a compatibility problem, please try to disable the AJAX submit form, like this:
Edit the post form "Edit Listing"
hidden link
in section "Other settings", disable option "AJAX submission", save it, and test again.

#1088569
7.png

I can live with that. Any ideas when the bridge plugin will be ready to roll for Yoast? 🙂