Skip Navigation

[Résolu] CRED repeating field

This support ticket is created Il y a 6 années et 7 mois. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Aucun de nos assistants n'est disponible aujourd'hui sur le forum Jeu d'outils. Veuillez créer un ticket, et nous nous le traiterons dès notre prochaine connexion. Merci de votre compréhension.

Sun Mon Tue Wed Thu Fri Sat
- 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Kolkata (GMT+05:30)

Ce sujet contient 3 réponses, a 3 voix.

Dernière mise à jour par Minesh Il y a 6 années et 7 mois.

Assisté par: Minesh.


I have a cutom post type name : repertoires, that contain a parent-child relation repeating field name activity. so in simple form, ONE repertoires can have multiple activity...

the parent-child relation work FINE, in repertoires, i can create multiple activity, and show it in VIEW !... it's all fine...

But those repertoires have front end access to modify there profile (it work)... but cannot on the frond end form submission they CANNOT create activity....

the question is HOW TO MAKE activity (the reapeating field) modifiable on the cred form frond end edition

here is the login password for the site....
lien caché
user : toolset
psw: ****


Dear Marc,

For security reason, I removed the password of your post.

Here are detail steps:
1) Create a CRED form for editing post of post type "Activités":
lien caché

2) Put above CRED form into a content template "Edit activite post CT":
lien caché

3) Edit the view "repeating-activite", in section "Loop Output Editor", insert edit link with the shortcode [toolset-edit-post-link ...], more help:

4) Edit the content template "Template for Répertoires":
lien caché
add the view's shortcode:

<h2>Edit child repeating-activite</h2>
[wpv-view name="repeating-activite"]

5) Your theme does not support Views content template, so I switch it to wordpress default theme 2015

Now you can test it in the front-end:
lien caché
section "Edit child repeating-activite"

For the problem of step 5, I suggest you try to use wordpess function the_content to render the post content, if you need assistance for it, please create new thread for it. thanks


the problem is not (now) edititon, but ADDIND it....



Les langues: Anglais (English )

Fuseau horaire: Asia/Kolkata (GMT+05:30)

Luo is on vacation. This is Minesh here and I'll take care of this ticket and try to help you further. Hope this is OK.

Could you please describe your problem in brief and share problem URL and access details.

*** Please make a FULL BACKUP of your database and website.***
I would also eventually need to request temporary access (WP-Admin and FTP) to your site. Preferably to a test site where the problem has been replicated if possible in order to be of better help and check if some configurations might need to be changed.

I would additionally need your permission to de- and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important. If you agree to this, please use the form fields I have enabled below to provide temporary access details (wp-admin and FTP).

I have set the next reply to private which means only you and I have access to it.

Ce ticket est maintenant fermé. Si vous êtes un client de Toolset et que vous avez besoin d'aide, veuillez ouvrir un nouveau ticket d'assistance