Skip Navigation

[Résolu] CRED form creating duplicate posts and other issues after most recent update

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 12 réponses, has 3 voix.

Last updated by Tom Gonzales Il y a 3 années et 5 mois.

Assigned support staff: Minesh.

Auteur
Publications
#613981
sample-email-notification.png
sample-all-listing-camp.png

I am trying to: Create custom post types using a CRED form on the frontend. This is a process I copied over from another site using the Modules tool, and it's working correctly on that site.

Link to a page where the issue can be seen: hidden link

I expected to see: When you hit submit, the form is submitted and the auto-response message displayed, and then a new custom Kids Camps post is added to the backend in Pending status.

Instead, I got: When I hit submit, the form is submitted and the auto-response message displayed, but when I go in the backend into the Kids Camp post section, there are 2 new posts added. One contains the correct post title submitted, and the description and logo image, but nothing else. "Girl Scouts of Northeast Texas Summer Camps — Pending"

The other listing has a title of "CRED Auto Draft 4d055c51d7afb81b440a8e6a07f6729d — Pending" and contains all the other form information submitted except the post title, description, and logo image.

I also have notifications set up for the form, and I'm using the shortcode to include the post title in the email message, but it only includes the title from the second post - “CRED Auto Draft 4d055c51d7afb81b440a8e6a07f6729d“.

This same process using the same theme works fine on another site, the only difference is that I updated the CRED plugin this morning before I started working on the form and testing. Wondering if that might be the cause.

I can provide you with Admin access once I receive a private link.

#614068

Minesh
Supporter

Languages: Anglais (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello. Thank you for contacting the Toolset support.

Well - Few users already reported this issue lately but with every user we found that we are having compatibility issue with different plugin.

In order to minimize the cause of the issue and to know which plugin is the cause in your case:

Could you please try to resolve your issue by deactivating all third-party plugins as well as the default theme to check for any possible conflicts with any of the plugins or themes?

#614077

Okay, I found this reference on your site regarding the plugin Relevannsi and uploading images in the CRED form, which worked fine before this most recent update.

I applied the fix found on this page: https://toolset.com/errata/cred-auto-draft-posts-created-when-relevannsi-cred-and-featured-images-are-used/

But it didn't work. When I tried to submit the form I got an error message asking me to use a valid URL where the image can be found.

So when I disable Relevannsi, the form works fine, and images are uploaded along with all other form information into a single custom post. But I use Relevannsi for a better search experience on the sites, and it use to work fine before the most recent CRED update. So how do I fix this so I can still use the plugin?

#614079

Minesh
Supporter

Languages: Anglais (English )

Timezone: Asia/Kolkata (GMT+05:30)

Ok - good to know that you found the faulty 'Relevannsi' plugin that causes the issue.

Could you please share problem URL where I can see CRED form.

*** Please make a FULL BACKUP of your database and website.***
I would also eventually need to request temporary access (WP-Admin and FTP) to your site. Preferably to a test site where the problem has been replicated if possible in order to be of better help and check if some configurations might need to be changed.

I would additionally need your permission to de- and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important. If you agree to this, please use the form fields I have enabled below to provide temporary access details (wp-admin and FTP).

I have set the next reply to private which means only you and I have access to it.

#614530

Just following up. I noticed you haven't accessed the Duplicator package I provided.

Wondering if I should roll back to the previous version of CRED until you guys figure out what the issue is, since all the plugins and the forms worked fine with the previous version of CRED?

#614532

Minesh
Supporter

Languages: Anglais (English )

Timezone: Asia/Kolkata (GMT+05:30)

Well - It was a big package and I downloaded it and I will try to debug this today and will get in touch with you as soon as possible.

#614702

Minesh
Supporter

Languages: Anglais (English )

Timezone: Asia/Kolkata (GMT+05:30)

I've escalated this issue to next level support. Please hold on, I'll get in touch with you as soon as possible as I know more.

#615194

Minesh
Supporter

Languages: Anglais (English )

Timezone: Asia/Kolkata (GMT+05:30)

Our Devs shared the patch that you should try in order to resolve your issue:

Please find patch with the following link:
=> https://toolset.com/errata/cred-auto-draft-posts-created-when-relevannsi-cred-and-featured-images-are-used/

#615343

Ok - In one of my previous messages to you, I indicated that I had already tried this fix and it didn't work. We're you able to get it to work?

I'll try again, just incase you guys have made changes to the original script I found here earlier:

https://toolset.com/errata/cred-auto-draft-posts-created-when-relevannsi-cred-and-featured-images-are-used/

Also - if you do try applying this on your end, please disable the auto email notification to the end-user submitting the listing - since this is a test, or replace it with your own email to confirm it works fine too.

Thanks!

#615382

Minesh
Supporter

Languages: Anglais (English )

Timezone: Asia/Kolkata (GMT+05:30)

Well - I got the information from next level that it's an updated errata that is why I asked to you apply patch but unfortunately its not working for you.

Please allow me to consult our Devs again and I'll get in touch with you as soon as I know more.

#615996

Dear Tom, the errata has changed since you first used it.
On February the 8th when you reported to have applied the fix here:
https://toolset.com/errata/cred-auto-draft-posts-created-when-relevannsi-cred-and-featured-images-are-used/
that errata did hold only a workaround.

Now, it holds a patch.
This is a file that you need to apply to the Plugin.
Please read the errata carefully as there are 2 possible solutions and you will apply only one of them, the patch.

February the 10th we added that patch, hence you cannot have it applied the 8th, correct?

Please, can you confirm that using a fresh copy of Toolset CRED, removing the Custom Filter from functions.php that you firstly added, and then applying the patch, the issue is solved?

I personally tested this patch on one user's duplicator and a clean site where the issues where replicated and fixed by the patch

Thank you

#616071

Ok - thanks for the clarification. I'll apply the new patch and let you know if it solves the issue.

#616143

I applied the patch and it did the trick.

Thanks for the help!