Skip Navigation

[Fermé] CRED Date Picker Problem

This support ticket is created Il y a 9 années et 2 mois. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 10:00 – 19:00 10:00 – 19:00 10:00 – 19:00 10:00 – 19:00 10:00 – 19:00 -
- - - - - - -

Supporter timezone: Europe/Madrid (GMT+01:00)

This topic contains 12 réponses, has 3 voix.

Last updated by jamesK-2 Il y a 8 années et 11 mois.

Assigned support staff: Caridad.

Auteur
Publications
#168461

I am having a lot of trouble with the CRED date picker in my forms.

I am using
CRED 1.2.4
Types 1.5.2
Views 1.4.1

In WP General Settings I have "j F Y" set

I enter a date June 13 2014 and it gets stored/returned as January 6 2015

I updated to all the latest software versions to see if it went away but it is still wrong.

I even regenerated the CRED create for and it is still wrong.

Any ideas as I am stuck!

Tony

PS
All dates entered switch the month and day round unless that results in an invalid month when it moves on to the following year.

#168508

Dear Tony,

Normally CRED requries a command before the year, try using June 13, 2014 and it should work.

Please let me know if you are satisfied with my answer and if I can help you with any other questions you might have.

Regards,
Caridad

#168539

Hello Caridad

Sorry I am not understanding what I need to change.

I set up a post type with dates in it.

I set up a CRED form to add a new post and the dates get scrambled.

Go to
hidden link

Click Administration to see the form

Password is (xxxxx)

(note that the dropdowns are not displaying right - another problem)

Now enter Event name as "test"
start date as 13 June 2014 (using date picker)
end date the same date

click submit

Now look at the (wrong) dates in the post display page.

How do I fix this?

Regards
Tony

#168648

I just set up a new domain and CRED form and the dates worked fine but the software versions were the old ones:

CRED 1.2.3
Types 1.4.0.2
Views 1.3.1

I am reluctant to updrade this site to the latest versions but maybe this will help.

Tony

#168950

Dear Tony,

Im using latest versions and I dont see that problem.

I’ll send you a private email right now asking you for some private information that will help me debug this issue for you. Please check your email in a couple of minutes, and if you don’t get it, let me know so I can send it again.

Thanks.
Caridad

#168972

Details sent - many thanks
Tony

#170007

Hello Caridad

Did you manage to find anything wrong - I just set up a new CRED form from scratch with 31 Dec 2014 as event date and it shows 12 July 2016.

I also added a date field to another post type and got the same error.

Regards
Tony

#170024

Hello Caridad

I am pretty certain that is is a bug of some sort.

I set up a cred form in another domain using cred 1.2.3

Test 1 - the date worked fine.

I updated cred to 1.2.4

Test 2 - the date recorded was wrong.

I then updated types and views to latest versions.

Test 3 - the date was wrong

I then recreated the cred form.

Test 4 - the date was wrong

I then changed the cred form 2 from styled to Basic

Test 5 - the date was wrong

This test domain only has types and views plugins nothing else is active.

Regards
Tony

#170038

Dear Tony,

I still havent been able to reproduce your problem on our servers, but we have another user with the same issue as you. I will forward the information to the developers and get back to you when I have more information.

Regards,
Caridad

#170048

Thanks Caridad

I just rolled back CRED to 1.2.3 in my test domain and the problem has gone away.

Hopefully this will be fixed soon.

Regards
Tony

#170990

Dear Tony,

We could finally reproduce the problem and forwarded a report to the developers. I will write back when I know something.

Regards,
Caridad

#171793

Dear Tony,

You should get a test version in your email today or tomorrow.

Please test it and let us know if it worked.

Thanks,
Caridad

#197335

Hi CaridadZ,

I am having the same issue could you please send me fix asap. My website is almost finished and only this issue stop it to go live.

So please email me the fix.

Thank you.

Le sujet ‘[Fermé] CRED Date Picker Problem’ est fermé à de nouvelles réponses.