Skip Navigation

[Résolu] CRED Clear previously selected parent problem

This support ticket is created Il y a 9 années et 1 mois. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Hong_Kong (GMT+08:00)

This topic contains 10 réponses, has 3 voix.

Last updated by tony Il y a 9 années.

Assigned support staff: Luo Yang.

Auteur
Publications
#181356

I have a CRED form that includes a parent selction and this works fine except when I want to change a previous parent to the "No Parent" option. The selection gets ignored and I have to go into WordPress to do the update.

I am using CRED 1.2.3 and am awaiting the next CRED version before updating.

Is this a bug?

Tony

#181617

Luo Yang
Supporter

Languages: Anglais (English ) Chinois simplifié (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Hi Tony,

Thanks for the feedback, I have been able to duplicate same problem in my localhost and put it into our to-do list, our developers will take care of it.

#181629

Thanks Luoy

I just discovered another problem with parent links that may be related.

In CRED form if a post type links to a parent of the same post type, the CRED form does not display the link in the field, it displays "No Parent ..." even though a link exists.

Regards
Tony

#182317

Luo Yang
Supporter

Languages: Anglais (English ) Chinois simplifié (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Could you describe detail steps to duplicate same problem?

In CRED form if a post type links to a parent of the same post type, the CRED form does not display the link in the field, it displays "No Parent …" even though a link exists

Thanks

#182387

Hi Luoy

The easiest way to describe the problem is to let you see the CRED form on the website.

I will send the logon details to you.

Then go to
hidden link

at the bottom of this page, click "Edit Event" to go to the form:
hidden link

The bottom dropdown selection shows:
"No Parent Sailing Event"

It should display
"2014 Club Sailing (Sep 21)"

If you select the parent and Submit you will see that the link does not show when you display the form again.

Regards
Tony

Logon details sent to you email.

#183649

Dear Tony,

I'm Adriano and I will help you with this issue. Please send credentials to me as well, place the URL of this ticket in the subject's email.

#184012

Details sent

#184410

Luo Yang
Supporter

Languages: Anglais (English ) Chinois simplifié (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Are we talking about the dropdown menu "Event Type", I see it is selected with option "Sailing"
hidden link

#184504

No - that is working fine.

At the bottom of the form there is another dropdown to a parent event. Just above:
"This field is rarely used and when it is used, it usually links to a Sunday Club Sailing Event."

The Barts Bash event is actually linked to a parent event "2014 Club Sailing (Sep-21)" but the link is not selected as the current value in the dropdown list.

Thanks
Tony

#187070

Luo Yang
Supporter

Languages: Anglais (English ) Chinois simplifié (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

For the second question:
Please try replace the codes in your CRED form from:

...
[cred_field field="post_parent" value="" order="title" ordering="asc" no_parent_text="No Parent Sailing Event"]
....

With:

[cred_field field="post_parent" value='[wpv-post-id id="$parent"]' order="title" ordering="asc" no_parent_text="No Parent Sailing Event"]

‘value’=> [optional] Preset value (translated automatically if WPML translation exists)
https://toolset.com/documentation/user-guides/cred-shortcodes/#cred-field

#187795

Thankas Luoy

That seems to do the job - defaulting to itself if no parent exists is fine.

Regards
Tony