Skip Navigation

[Résolu] Classifieds Listings are not searchable in wp-admin

This support ticket is created Il y a 6 années et 10 mois. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 8:00 – 17:00 8:00 – 17:00 8:00 – 17:00 8:00 – 17:00 8:00 – 17:00 -
- - - - - - -

Supporter timezone: America/Sao_Paulo (GMT-03:00)

Marqué : 

This topic contains 7 réponses, has 3 voix.

Last updated by Adriano Il y a 6 années et 9 mois.

Assigned support staff: Adriano.

Auteur
Publications
#363259
search listings.jpg

Hi,

I'm using the Classifieds reference site, and have nearly 150 posts in the "Listings" category.

When I try to use the search to find a specific listing, so that I can modify it, the search always returns no results.

I'm guessing that there must be a very simple solution to this.

Many thanks
Alan

#363350

I have created a discover-wp.com Classifieds Framework site with WPML and Layouts, and I can't reproduce that issue.

You can see the site here:
hidden link
User:
beda
Password:
$(WfJLfD&*^D

As you see I can freely search and find Listings.

That must be either a Database corruption, a server issue or a capability issue with another Plugin.

Can you let me know if that issue is solved with Toolset only, no cache, and can you let me know if this happens locally as well, or on another Server/install you have?

I would suggest to re-create the Site to see if it fixes the issue, but that depends on the content you already created.

Thank you

#363411

Hi Beda,

I think I have narrowed down the cause of this issue.
The "Expiry date" field is not needed in my site, and so I removed it from the Cred form and made it so that it is not required in the custom fields definitions.
A few of the initial listings I created which have an expiry date, DO appear in the search.
However, the site now has 160 listings and 155 of them have no expiry date, and do not show up in the search. (this is only on the search within the Wp-admin. The front end search still works for all listings.)

I could just automatically enter an expiry date a hundred years from now, but I'm hoping that it would be quite simple to fix this issue properly.

Hope you can help
thanks
Alan

#363413

Hello again Beda,

I found the solution, and will just write it up here in case it helps someone else.

Within plugins/toolset-classifieds/inc there is a file called toolset-classifieds.class.php

Lines 95 and 96 look like this:

//Filter to exclude listings without expiration from being included in search
       add_filter( 'the_posts',array( $this,'classifieds_searchfilter' ), 99, 1 );

Just comment out this filter and the search will pick up everything, regardless of Expiry dates.

Thanks

#363602

I am reopening this ticket because even if you solved the issue on your end, there is something to review here as I believe.

I escalate it now to the 2nd tier Support for review.
I believe it is wrong to change the WordPress Query in the Backend this way, requiring you to change Plugin's Code.

No further action is required from you, I just reopen this ticket so we can update it in case any code changes will be implemented.

I thank you fro bringing our attention to this.

#365919

Hello,

I’m Adriano, Toolset support lead and I have been escalated to this thread. I’ll give my best to help you to achieve your needs through Toolset components.

I've forwarded the issue with a proposal fix to our development team, they should take care of it in the next release. Thank you for raising this. For any kind of issue please open a new thread.

#366743

Thanks guys

#366847

You are welcome.