Skip Navigation

[Résolu] Cannot Get Markers to Show on Map / Errors on Geocoding API

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 3 réponses, has 2 voix.

Last updated by marcusC-4 Il y a 5 années et 2 mois.

Assigned support staff: Minesh.

Auteur
Publications
#429775
maps-api-errors.jpg

I cannot get markers to appear on maps. I have setup a test site with the 2015 theme, no other plugins active, and no modifications to the template files. I created a CPT called "Houses" & added an address field to it.

I have followed all instructions on this page: https://toolset.com/documentation/user-guides/display-on-google-maps/

I have a working API, which I will detail more below.

When I enter an address on my CPT, the map to the right works great & the address field allows me to choose the address as soon as I start typing. Everything is good so far...

After publishing the House post, I created a content template with a map & marker on it -- using the "address" field type I created. The webpage shows the map, but no marker: hidden link

I created another page & tried to manually insert an address using the shortcode generator. I created a map, then created a marker & chose the "an address" option. As I started typing my address, the API worked again & allowed me to choose it. I have published that page, but no marker appears: hidden link

I have double checked in each case to make sure the Map-ID corresponds correctly between the map shortcode & the marker shortcode.

I know the API is working, because I can see in my API Dashboard that the JS API & Place APIs have successful calls & that the Geocoding API has 100% errors. I have attached a screenshot of this dashboard. Clearly, the API is being requested, but won’t work for Geocoding.

I have double-checked that the correct URL has been added to my Browser Key. I have also checked the JS Console for error messages & don’t see any.

I’m happy to provide Admin access to this site or anything else you need to help resolve the issue.

#429974

Minesh
Supporter

Languages: Anglais (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello. Thank you for contacting the Toolset support.

1)
you must try to create new API and make sure following APIs are enabled:
- Google Maps Geolocation API
- Google Maps JavaScript API
- Google Places API Web Service

Does this help?

2)
If #1 does not help:

Please share problem URL where you would like to display the markers.

*** Please make a FULL BACKUP of your database and website.***
I would also eventually need to request temporary access (WP-Admin and FTP) to your site. Preferably to a test site where the problem has been replicated if possible in order to be of better help and check if some configurations might need to be changed.

I would additionally need your permission to de- and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important. If you agree to this, please use the form fields I have enabled below to provide temporary access details (wp-admin and FTP).

I have set the next reply to private which means only you and I have access to it.

#430200

Minesh
Supporter

Languages: Anglais (English )

Timezone: Asia/Kolkata (GMT+05:30)

I've setup my test google map API key and I can see that map market is working.
=> hidden link
=> hidden link

The issue is from your map API key setup and not with Toolset map. Please replace my test key with your key.

#435922

Finally found the issue. It was with a plugin called "Simple Real Estate Pack". I don’t know why it didn’t resolve when I deactivated all plugins but for some reason, it resolved when I just deactivated that one & left other plugins active. Maybe I didn’t give time for server cache to clear before testing???

Anyway, thanks for helping! Turns out it was an issue on our side & had nothing to do with the API.

Marcus