Skip Navigation

[Résolu] All filter options clear results

Ce fil est résolu. Voici une description du problème et la solution proposée.

Problem: Using two or more Types checkboxes fields inside a Views parametric search can produce wrong results when selecting options from more than one field.

Solution: Apply this fix or use Views 1.12+ https://toolset.com/errata/filtering-by-multiple-checkboxes-fields-fails-to-return-results/

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Marqué : 

This topic contains 18 réponses, has 2 voix.

Last updated by OliverJ8211 Il y a 5 années et 7 mois.

Assigned support staff: Beda.

Auteur
Publications
#367890

I am trying to: Use the parametric search

I have types and views on hidden link and that is the page I'm using for parametric search view.

But when I select any option it clears the results. But the 1 item I have in the custom post type is using all the options. i.e. there are checkboxes for games. On the single item listing I have all the games checked so checking any game should keep the listing there but it makes it disappear and I get no results.

Let me know if you need more info.

#367965

Thank you for contacting us here in the Support Forum and for providing the Debug Informations

It would be good that you first update your Toolset to it's latest version. Can you do this please?

❌ Be sure to backup your database first before you proceed! ❌
⌥ You can use a plugin for this if you like.
I often use the Duplicator plugin for this purpose.
See: http://wordpress.org/plugins/duplicator/

As I tested that Parametric Search, it seems the Content (the only one single game) is not holding the attributes you query for, in simple words, it's not in those taxonomies and has not those values of Custom fields as in the Parametric Search.

To debug this issue I personally would follow as this:

1. Delete all Parameters from your Search in the View (From the Code editor and the Query Filter section)

2. Control your single game post if all is set and all fields/taxonomies are added

3. Save the Post again

4. Go back to the View, and make sure to add each Parameter for the Search one by one

5. Check the View output every time you add a parameter

6. Reprot to me which parameter is introducing the issue.

If you are sure the post holds all parameters, and it's still not working, you might need to test with Toolset only and a default theme to be sure it's not interfering.

If then the issues still happen, I would eventually also need to request temporary access (WP-Admin and FTP) to your site
- preferably to a test site where the problem has been replicated if possible -
in order to be of better help and check if some configurations might need to be changed

Your next answer will be private which means only you and I have access to it.

❌ Please backup your database and website ❌

✙ I would, if possible, need access to a site where only a minimal set of Plugins and a default theme is active.
This to avoid eventual compatibility issues with other software.

✙ Please add the Links to:

- The Views Edit Screen

- The Page/Post where you insert the View

- The corresponding Front End Page/Screen

- The corresponding Post (game) and fields/taxonomies.

Thank you

#368901

Your Website is using a Cache Plugin or server side cache?

I tried a few things there and it seems you experience Cache issues.

As example new created Views need to be reloaded many times before they display only the desired content and even there, filters brake if set to return results in AND comparison.

I need to debug this locally since that's a Life site.

I would need a sites snapshot if possible.
We usually recommend the free Plugin "Duplicator" for this porpoise.

If you already know how Duplicator works
(http://wordpress.org/plugins/duplicator/),
please skip the following steps and just send me the installer file and the zipped package you downloaded.

★ Duplicator Instructions
hidden link
Send me both files (you probably want to use DropBox, Google Drive, or similar services, as the snapshot file will be quite big)

❌ IMPORTANT ❌
Remember to create or keep an admin account for me before creating the snapshot, or I won't be able to login. You may delete the new admin account once the snapshot has been built.

I will enable your next answer as private so you can provide me the information securely.

Please could you provide me the additional Infos?

Thank you for your patience.

#369653

I can not share my company email with the public, I apologize this Company Policy.

Instead, you can share your Google Folder with "anybody that has this link"

I will enable a Private answer, and you can provide that Link.

Only me will then have access to it.

Thank you so much for your patience and comprehension.

#370048

I am downloading the folders now.

Please allow the system time to fetch the files and then I will replicate this as soon as possible,

Thank you.

Meanwhile, I might ask, if any taxonomy is involved in your Parametric Search.
(As far I recall no)

If so, we discovered a BUG, which can produce results as you experience and our DEV is preparing a Errata Entry for it.

Please keep your eyes on this list and try (locally or on DEV Site) to apply the fix:
https://toolset.com/errata/taxonomy-filter-on-a-parametric-search-is-not-displaying-any-options/

Please expect my informations here in the forum.

Thank you for your patience.

#370158

I was finally able to reproduce this.

The issue happens when you have moire then one field of type "Checkboxes" on the same post type.

Then, if the View is updated via AJAX, you can only and always select one checkbox to see results.
As soon you select more then one, results are cleared.

The DEV is on it now.

Please expect my informations here in the forum.

Thank you for your patience.

#370257

We have a fix for this:
https://toolset.com/errata/filtering-by-multiple-checkboxes-fields-fails-to-return-results/

Please apply the fix only after a full backup of your database and website

Thank your patience

#370377

Thank You! That fixed the checkboxes issue but did not fix the timezone issue.

OK I got the timezone(it was removed from the Query Filter section) to work but now if they select a checkbox it automatically uses the midway islands timezone.

#370389
Default_Drop_Down.png

Got it to work but it was hard because I could not set the default time zone to Any timezone because the options were behind the edit filter pop up. SEE ATTACHED.

Working as should now.

#370392

Nevermind. Thought it was working. But now if I select "ELITE: Dangerous, CS:GO and Pacific Timezone it shows no results even though 1 of my listings matches all the criteria.

In fact choosing any timezone but Midway now clears the results.

Is this a beta?

#370502

This issue is a older one and known:
https://toolset.com/forums/topic/all-filter-options-clear-results/#post-370389

The Solution has been already implemented in Views.

This should not happen anymore.

I suggest the following approach:

1. Reinstall all Toolset Plugins (I am truly sorry for that) manually.

2. Apply the Fix I provided above in the Types Plugin

3. Repeat the Steps token.

On my end the Custom Field of type "Select" is correctly working (see screenshot)

Do I understand it correctly, that the Search is now working, unless the Time Zone "Select Field"?

This is working fine on my end after applying the Fix.

You need to make sure, that if you enter values manually, you enter the exact value stored in the DDBB for this Fields Options.

Please let me know if the above solution works for you, I look forward to your reply!

Thank you for your patience.

#370506

"You need to make sure, that if you enter values manually, you enter the exact value stored in the DDBB for this Fields Options." <--it's a dropdown select I'm not entering fields manually. Please check hidden link and select any timezone but midway islands and it will clear the results.

Obviously by my screenshots the issue is not fixed.

Don't take this the wrong way but everything I do with this toolset is broken. No conditional on checkboxes, filters not working right, woocommerce views not working and more.

#370508

Here I even have your test view that is using checkboxes hidden link and the timezone still doesn't work.

#370509

Even your test view doesn't work. hidden link

On my end the Custom Field of type "Select" is correctly working (see screenshot) <--what screenshot?

#370525

I may have found the issue. I noticed that in the "Edit Post Field Group" page for the Ohmega Profiles that the Midway "Custom field content" was just "Midway Islands Time" with out the "GMT-11:00". I have changed all the other timezone "Custom field content" to not have the "GMT-11:00" I think the - or : was causing the issue. I will be re-creating the custom post types now to test.