Skip Navigation

[Résolu] 500 Internal Server Error when I edit any post

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Marqué : 

This topic contains 3 réponses, has 3 voix.

Last updated by Beda Il y a 2 années et 9 mois.

Assigned support staff: Christian Cox.

Auteur
Publications
#948509
Screen Shot 2018-07-16 at 10.10.37 PM.png

Hi Team,

I am getting a 500 Internal Server Error when I edit any post on the website in.leisurekart.com.

Screenshot attached.

Kindly help.

Below is a reply / help I received when I contacted my web host regarding this:
---
This 500 error is caused by the Cred-Frontend=Editor plugin. The error posted below indicates a coding issue in the plguin. I would advise contacting the developer for help with this.

In the meantime, I was able to post edits using the default WordPress editor. So this should be a workaround while working to get the plugin issue resolved.

PHP Fatal error: Uncaught InvalidArgumentException: First argument is not a post. in /leisurekart-india/wp-content/plugins/cred-frontend-editor/vendor/toolset/toolset-common/inc/autoloaded/field/group.php:60

Please let us know if there is anything else we can help with.
---

#948691

Christian Cox
Supporter

Languages: Anglais (English )

Timezone: America/New_York (GMT-04:00)

Hi, can you try these troubleshooting steps first?
- Deactivate and delete Toolset Forms (CRED) and Toolset Types, then download the latest versions from https://toolset.com/downloads and reinstall them.
- Temporarily switch to a default theme like Twenty Seventeen, deactivate all plugins except Types, Views and Forms, and test again. If the problem is resolved, please reactivate your parent theme, then child theme, then other plugins, one by one until the problem returns.
- If the problem was not resolved, I'll need to take a closer look.

#957334

Hi Christian,

Apologies for the delay in replying.

I do not need help with this as it got fixed in the recent update or not sure how.

Thanks!

#1125137

This was probably related to this bug:
https://toolset.com/download/toolset-types/#changelog
https://toolset.com/forums/topic/uncaught-exception-invalidargumentexception-vendor-toolset-toolset-common-inc/#post-1124532

It's now solved, please open a new ticket in case similar issues (or others) pop up.