[Resolved] [wpv-post-author] shortcode showing different author when in a div

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

No supporters are available to work today on Toolset forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

This topic contains 2 replies, has 2 voices.

Last updated by tylerR-3 3 years, 8 months ago.

Assigned support staff: Shane.

Author
Posts
#414563

Hi there, this is a bit complicated to explain but I'll try my best. I have a real estate site and trying to use the [wpv-post-author] to display the author of the property (want to do some css targeted to all the posts by a certain author).

My real estate theme is set up so that a custom template page made in visual composer with shortcodes is how all properties on the site display. Each agent/user is the author of a property, however the template page is made by the admin, so it gets a bit complicated when trying to show the property author.

When I enter this shortcode into the template page, it works perfectly and displays the correct agent/author:

[wpv-post-author format='meta' meta='nickname' id='$parent']

However, as soon as I enter this in the template page (using the text tab for the WordPress page to wrap a div around a section of the template using the agent/author nickname as the class), it reverts to the template author, which is the admin, and won't display the agent/author name anymore:

<div class="[wpv-post-author format='meta' meta='nickname' id='$parent']">{some-content}</div>

How can I get this to display the author name while still in the div?

Thank you!

#415129

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Tyler,

Thank you for contacting our support forum.

I took this code and test it and the information was displayed correctly in both cases for me.

Taking a look at your plugins list I noticed that you have quite a number of them installed.

This is what could be causing your issue. What I recommend that you do is to temporarily disable all your non-toolset plugins and check again to see if the issue remains.

Thanks,
Shane

#415305

Thanks, I ended up using a 'do_shortcode' with the same shortcode directly in my page template instead of the editor and it worked.