Skip Navigation

[Resolved] wpv-add-to-cart-message not working

This thread is resolved. Here is a description of the problem and solution.

Problem:

The issue here is that the add to cart message is not showing up on the Product Page.

Solution:

This is a known issue and our development team is working to fix this issue.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 15 replies, has 2 voices.

Last updated by Sammut 1 year, 7 months ago.

Assigned support staff: Shane.

Author
Posts
#1194493

Upon review, the docs, and support forum integrating the wpv-add-to-cart-message shortcode yields nothing. It just shows an empty white box and it also arbitrarily shows up, bot in a grid or formatted. Any tips or help?

#1194511

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Sammut,

Thank you for contacting our support forum.

Are you adding this to an archive page or is it a regular product page template.

Please let me know.

Thanks,
Shane

#1194516

Thank you!!
This is being added to a content template for a regular product. Non-archive.

#1194520

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hello,

Would you mind providing me with access to this so that I can check on this issue for you ?

The private fields have been enabled.

Thanks,
Shane

#1195441

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Sammut,

It seems you protected the products on the frontend.

Would it be ok if allowed only admins to view the products on the frontend?

This way I can test out the issue ?

Thanks,
Shane

#1195569

I added the pw to private notes. Thank you!

#1195593

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Sammut,

I was able to see the issue.

However to ensure we are not working with some form of plugin conflict hiding this text.

Could you temporarily disable the non-toolset plugins and again as this works prefect on a fresh installation.

Looking forward to hearing from you on this.

Thanks,
Shane

#1195630

Hi Shane,

Actually, we already did that, plus flipped to 2019 theme, before we reached out.

#1195657

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Sammut,

Thank you for confirming.

Just wanted to ensure that this was not the issue.

I would to take a copy of the site to work on here locally as it seems This is not just an issue of it being hidden by css or such.

If that is ok with you I will be using the duplicator plugin to grab a copy.

Thanks,
Shane

#1195665

Yes! Your help is very much appreciated!

#1196011

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Sammut,

Just an update on this one.

I was able to successfully setup the duplicator package and now working on the copy.

However I was swapping the theme on your site just for a quick test and swapped back to your theme but the products are now using a full width layout.

Is there some setting in the theme that I need to change to restore the original display ?

#1196076

Oh yes, sure, just go into Toolset -->WooCommerce Views and under Product Template File select Mood Indigo Living Theme Custom Product Template.

Thanks!

#1196107

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Sammut,

So our 2nd tier investigated this issue and its actually a known issue.
https://toolset.com/errata/added-to-cart-success-message-is-not-displayed-on-content-templates-styling-products/

Not much else we can do about this here since its in the hands of our development team to fix.

What I recommend that you do is to keep following the errata page that i've sent to keep up to date when this is fixed.

Thanks,
Shane

#1196116

OK, yikes. That is pretty important shortcode to not work correctly. Thank you!

#1196140

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Sammut,

Yes that is true. I hope this is fixed soon.

Is there anything else that I can assist with ?

Thanks,
Shane