[Resolved] WPBakery not loading to edit view

This thread is resolved. Here is a description of the problem and solution.

Problem: I'm trying to load the WPBakery builder to edit a View template, but the page is blank.

Solution: It looks like the preferences for editing this template should be reset. - Temporarily deactivate all plugins except Types, Views, and WPBakery Page Builder. If you want to use a Maintenance Mode plugin during this process, that's okay. Temporarily activate the Twenty Nineteen theme. - Go to WPBakery Page Builder > General Settings and check the "Disable" checkbox to disable Gutenberg Editor. - Go to Toolset > Content Templates and create a new blank Content Template. Do not assign this template to any post type or anything, leave it unassigned. Try to edit this new template with the WPBakery Page Builder. This process should reset the builder preferences and you should be able to edit templates with WPBakery correctly. - If the builder works for the new Content Template, try to edit one of your existing templates again using WPBakery. - Re-check the "disable" checkbox in WPBakery Page Builder > General Settings if you prefer to keep Gutenberg disabled.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Cristian 8 months, 2 weeks ago.

Assigned support staff: Christian Cox.

Author
Posts
#1360711

Im trying to creat a template for a view on "Templates for this View"
I hit the button "Edit with WPBakery Page Builder"
A new tab is open but I can't see the WPBakery editor (Attaching screenshot)

#1360927

Christian Cox
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Hello, can you try the following troubleshooting steps?
- Clear your browser cache and test again.
- Temporarily deactivate all plugins except Types, Views and WPBakery Page Builder. Activate a default theme like Twenty Nineteen.
- Test again
- If the problem is resolved, reactivate your parent theme, then your child theme, then each plugin one by one until the problem returns
- If the problem is not resolved, I'll need to take a closer look.

#1361671

Ok so I did all those steps, problem persists even after leaven only those 3 plugins.

The user I've created in the pass for you guys is still available if you need to check by yourself, please let me know if you need the access info again.

Thanks

#1361693

Christian Cox
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Okay thanks for testing. Please provide credentials again in the private reply fields here. When older tickets are resolved, that data is deleted from our servers for security.

#1362099

Christian Cox
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Okay it looks like the preferences for Content Template editing with Gutenberg and WPBakery Page Builders are out of sync somehow. We should be able to fix this by temporarily changing a configuration in WPBakery and creating a new Content Template. Let me know if you would prefer to do this, or if it's okay for me to do it on the live site. Since you have a backup ready to go, it might make more sense for you to do it so you can revert quickly if necessary. Here are the steps to reset those preferences:
- Temporarily deactivate all plugins except Types, Views, and WPBakery Page Builder. If you want to use a Maintenance Mode plugin during this process, that's okay. Temporarily activate the Twenty Nineteen theme.
- Go to WPBakery Page Builder > General Settings and check the "Disable" checkbox to disable Gutenberg Editor.
- Go to Toolset > Content Templates and create a new blank Content Template. Do not assign this template to any post type or anything, leave it unassigned. Try to edit this new template with the WPBakery Page Builder. This process should reset the builder preferences and you should be able to edit templates with WPBakery correctly.
- If the builder works for the new Content Template, try to edit one of your existing templates again using WPBakery.
- Re-check the "disable" checkbox in WPBakery Page Builder > General Settings if you prefer to keep Gutenberg disabled.

Let me know how you would like to proceed.

#1362985

My issue is resolved now. Thank you!

Cool , I've follow your instruccions and now is working, just one question, did you happend to edit the wp-config.php to enable debug file public??

just trying to find an answer for that now, thanks again

#1362993

Christian Cox
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I don't think so...I think I connected via wp-admin and not via FTP. I used the All-in-One WP Migration plugin that was already installed to create a clone of the site, then downloaded the clone directly from wp-admin. I don't think I would have had the ability to edit the wp-config.php file through the wp-admin dashboard...it would have required FTP or SSH access. I'm sure I didn't have SSH access, and I just checked my FTP client and I don't see any history of connecting to your server there. So I'm pretty confident it was not me.

#1363387

ok thanks!