[Resolved] WP Types causing an error

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by Seb Gates 4 weeks, 1 day ago.

Assigned support staff: Christian Cox.

Author
Posts
#1472585

I tried to install Types on a website and WordPress would not allow me to upload it. I got warning messages.

In the end I FTP the folder up to the hosting account and activated the plugin and it worked.

Now when I try to edit a page or do anything basic with the website, I get the following message (attachment 1)

I also get the following message by email when I deactivate the plugin and reactivate it again:

Howdy!

Since WordPress 5.2 there is a built-in feature that detects when a plugin or theme causes a fatal error on your site, and notifies you with this automated email.

In this case, WordPress caught an error with one of your plugins, Toolset Types.

First, visit your website (hidden link) and check for any visible issues. Next, visit the page where the error was caught (hidden link) and check for any visible issues.

Please contact your host for assistance with investigating this issue further.

If your site appears broken and you can't access your dashboard normally, WordPress now has a special "recovery mode". This lets you safely login to your dashboard and investigate further.

hidden link

To keep your site safe, this link will expire in 1 day. Don't worry about that, though: a new link will be emailed to you if the error occurs again after it expires.

When seeking help with this issue, you may be asked for some of the following information:
WordPress version 5.3.2
Current theme: Bhakti Marga Country Website 2019 (version 3.0.1)
Current plugin: Toolset Types (version 3.3.9)
PHP version 7.0.33

Error Details
=============
An error of type E_ERROR was caused in line 412 of the file /home/bhaktiindia/domains/bhaktimarga.in/public_html/wp-content/plugins/types/vendor/toolset/toolset-common/lib/auryn/lib/Injector.php. Error message: Uncaught ReflectionException: Class OTGS\Toolset\Types\Compatibility\Yoast\Field\Factory does not exist in /home/bhaktiindia/domains/bhaktimarga.in/public_html/wp-content/plugins/types/vendor/toolset/toolset-common/lib/auryn/lib/CachingReflector.php:89
Stack trace:
#0 /home/bhaktiindia/domains/bhaktimarga.in/public_html/wp-content/plugins/types/vendor/toolset/toolset-common/lib/auryn/lib/CachingReflector.php(89): ReflectionParameter->getClass()
#1 /home/bhaktiindia/domains/bhaktimarga.in/public_html/wp-content/plugins/types/vendor/toolset/toolset-common/lib/auryn/lib/Injector.php(517): OTGS\Toolset\Common\Auryn\CachingReflector->getParamTypeHint(Object(ReflectionMethod), Object(ReflectionParameter))
#2 /home/bhaktiindia/domains/bhaktimarga.in/public_html/wp-content/plugins/types/vendor/toolset/toolset-common/lib/auryn/lib/Injector.php(464): OTGS\Toolset\Common\Auryn\Injector->buildArgFromTypeHint(Object(ReflectionMethod), Object(ReflectionParameter))
#3 /home/bhaktiindia/domains/bhaktimarga.in/public_html/wp-

#1473659

Christian Cox
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Hi, I'll be glad to take a closer look and help figure this out. Can you try the following troubleshooting steps first?
- If you are locked out of wp-admin by an error, please use FTP to go to /wp-content/plugins and rename the types folder to something like types-backup. This will temporarily deactivate Types and should allow you to log in to wp-admin again.
- Temporarily deactivate all plugins and activate a default theme like Twenty Twenty or Twenty Nineteen. Now reactivate Types.
- If the problem is resolved, reactivate your theme and other plugins one by one until the problem returns.
- If the problem was not resolved, I'll need to take a closer look. Please provide login and FTP credentials in the private reply fields here so I can continue troubleshooting.

#1473707

My issue is resolved now. Thank you!