Skip Navigation

[Closed] WordPress 4.2.3 update breaks shortcodes

This support ticket is created 7 years, 10 months ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 208 replies, has 94 voices.

Last updated by Amir 7 years, 10 months ago.


All seems to be working at my end.

Views now rendering correctly in Content Templates as well.

Thanks for your hardwork and dedication....


> So I tried to unsubscribe here, but all I get is an error message:
> "ERROR: Are you sure you wanted to do that?"

Try refreshing the page before clicking unsubscribe and it should work.



Thank you for the update. I've installed the Types 1.7.8-b1 version. It does render the WYSIWYG fields again without breaking the layout. SUPER!

One remark! Is it correct that "manual paragraphs" isn't working anymore? All my enters in the coding editor, are being converted into paragraphs in the output of the content template (the template is set to manual paragraphs).

Using latest beta_2 views and the beta types



Timezone: Europe/Madrid (GMT+02:00)

Hi herreV

Yes, we are aware of that too. But we though that a formatting ssue was better than a rendering issue, so we pushed the beta while we work on that.

Very happy to hear his is working for some of you 🙂

Screen Shot 2015-07-28 at 14.40.07.png
Screen Shot 2015-07-28 at 14.40.41.png

ADDITIONAL REMARK: This only happens when a WYSIWYG cf is added to the Content Template

See the images for... one with the WYSIWYG field and one without. It starts adding paragraps.


I hope that the VIEWS update dont messes up my mass edited Views which are working right now.





Sorry guys but it's Tuesday evening now - there is no solution for 4,5 days, just some betas which don't work ? Why ? It should be possible for a bunch of professional full-time programmers to fix this in a couple of hours?




I've since updated to
Types 1.7.8-beta1
Views 1.9.1-b2

It corrected a lot of issues. What I found was the Views using Intermediary custom post types did not work. Here is the view code that stopped displaying links. It has worked for a number of years until the 4.2.3 release.

<!-- wpv-loop-start -->
         [wpv-if evaluate="[wpv-post-id] <> [wpv-post-id id="$therapy"]"]
         <li><a href="[wpv-post-url  id="$therapy"]" title="[types field="therapy-intro"  id="$therapy"][/types]">[wpv-post-title  id="$therapy"]</a></li>
<!-- wpv-loop-end -->

I'm figuring it could just be syntax since it seemed before this update I could fix some of the issues on other sites by changing a " (double quote) to a ' (single quote).

If not syntax, is how this code is written a known issue that is being worked on?




I've since updated my code so that the double quotes are around the single quotes. It works with WP 4.2.3 combined with Types 1.7.7 and Views 1.9..

I then use this same code with the latest beta versions of T & V and WP 4.2.3 and I get no output.

<!-- wpv-loop-start -->
         [wpv-if evaluate="[wpv-post-id] <> [wpv-post-id id='$therapy']"]
         <li><a href="[wpv-post-url  id='$therapy']" title="[types field='therapy-intro'  id='$therapy'  output='raw'][/types]">[wpv-post-title  id="$therapy"]</a></li>
<!-- wpv-loop-end -->


@ronald, am I correct that you are checking the following...


is not the same as:

[wpv-post-id id='$therapy']"]

If so, you could try != instead of <>


In the midst of all the discontent about this unexpected WordPress security "fix" and the Toolset team's response, I simply want to thank the developers for pushing out a working beta of Views and Types that seems to work well with my WordPress 4.2.3 installation.

Thank you for all your hard work!


Thanks Ronald E for your post.
Same here: I've updated all my VIEWS (a lot of work) so that the double quotes are around the single quotes. It works with WP 4.2.3 combined with Types 1.7.7 and Views 1.9. Only some "wpv for each" are not working.
Every update of VIEWS which will come up MUST deal with these changes, if not everybody has to write uncorrect markup (refering to the WordPress API) to get VIEWS to work again.

The topic ‘[Closed] WordPress 4.2.3 update breaks shortcodes’ is closed to new replies.