Skip Navigation

[Resolved] WooCommerce Blocks Update has broken site

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Our next available supporter will start replying to tickets in about 6.67 hours from now. Thank you for your understanding.

This topic contains 2 replies, has 2 voices.

Last updated by nickP-12 1 month, 2 weeks ago.

Assigned support staff: Jamal.

Author
Posts
#1814165

I am using Toolset with WooCommerce and Elementor. My single product page templates have been built using Elementor.

The update to wooCommerce blocks has broken all my WooCommerce single product pages to the point where each page only displays an unformatted text description.

Disabling the plugin restores the pages but means data which has been obtained using the toolset plugin just displays the shortcode on the front end.

I'm hoping this is a known bug and doesn't require me to rebuild the single product template.

#1814671

Jamal
Supporter

Languages: English (English ) French (Fran├žais )

Timezone: Africa/Casablanca (GMT+01:00)

Hello and thank you for contacting the Toolset support.

We currently do not have any known issues with the latest version of our WooCommerce Views plugin. I suspect a configuration flaw.
Please check:
- No content template is assigned to the Products custom post type.
- In Toolset->WooCommerce Blocks, check that the Product template uses the default template from WooCommerce instead of the one from WooCommerce Views.

If this does not help, please check if this issue appears when:
- Only Toolset plugins and WooCommerce are activated. It will tell us if there is an interaction issue with another plugin.
- The theme is set to a WordPress default like Twenty Fourteen. It will tell us if there is an interaction issue with your theme.
If the problem disappears, start activating one at a time to track where the incompatibility is produced.

Otherwise, please allow me temporary access to check this closely, or provide a Duplicator copy of your website to check it locally. Your next reply will be private to let you share credentials safely. ´╗┐** Make a database backup before sharing credentials. **

#1814977

Hi Jamal,

Thankyou for the fast and helpful assistance. As you suspected the Toolset --> WooCommerce Blocks product templates had defaulted to WooCommerce Views. Reverting these back to WooCommerce Default resolved the issue.

I didn't think to check here!

Thanks, Nick