Skip Navigation

[Resolved] Woocommerce Archive still showing default theme layout over Views content

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Our next available supporter will start replying to tickets in about 1.28 hours from now. Thank you for your understanding.

This topic contains 10 replies, has 2 voices.

Last updated by Nigel 4 years, 4 months ago.

Assigned support staff: Nigel.

Author
Posts
#403487

I have a custom view set-up for WordPress Archive on Woocommerce product categories and have a table of products displayed. All was working well. However I have now added another category level which has changed how one of the pages is displayed.

Now on the category page which has sub-categories the View table is displayed with the theme Woocommerce layout on top of it, which obscures the table below.

Could you tell me what I need to do to remove the default theme layout from this page?

Many thanks.

#403658

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+00:00)

Hi Nic

I think rather than me trying to build a test site to do something similar it would be easier if I could work on a duplicate of yours to see your settings and work with your content.

Could you please create a snapshot of your site and upload it to a public url (such as dropbox or google drive) so that I can reproduce it locally.

* All-in-One WP Migration is simple to use https://wordpress.org/plugins/all-in-one-wp-migration/. Note I can only import archives up to 512Mb in size. If they are not relevant to your issue, you can omit media files which will reduce your archive size.

I will mark your next reply as private so that you can give me the url to retrieve the backup files.

Can you also confirm the url of where I can see the problem.

Thanks for your patience.

#403743

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+00:00)

Nic

All was going well until I came to enter the password, which it didn't accept.

I'll set your next reply as private again. If you have a different password for me to use than the one you already supplied let me know, otherwise it might be more straightforward if I log in to your site and make my own backup with All-in-One WP Migration which I can download directly.

I need the url for your site's admin page.

#403817

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+00:00)

The site has been recreated, now I just need to know where you've hidden the admin pages 😉

#403836

Great, I'm pleased it worked out.

Ah...I added the admin URL to a previous private reply (#403707).

#403837

The page that is causing issies is:

/hire-stock/guitar/

#403838

Oops...issues. 🙂

#403885

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+00:00)

I see the problem, including if I disable all non-essential plugins and switch to the default Storefront theme.

I has escalated this ticket so our developers can take a look.

In the meantime as a crude workaround you can simply hide the offending UI by adding this to your custom CSS on your custom product-category WordPress archive.

.wf-cell.iso-item.shown {
  display: none;
}

We'll keep you updated with any news.

Thanks for your patience.

#404678

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+00:00)

Hi Nic

The solution is actually rather mundane. You need to update your WooCommerce settings.

On the Products tab, choose the Display section, from where you can set the Default Category Display to show only products. Presumably it is currently set to display both products and sub-categories.

Let me know if that is not the case or does not fix the problem.

#404693

Hi Nigel,

It's great when the solution is so simple.

I had looked at those settings when I was setting Toolset up, however it hadn't occurred to me to go back and look at it.

At the moment I don't believe that I need the sub-categories to show above the items themselves on that page. However, if I did need them to be displayed then how would I be able to control the style and layout of the categories that had been overlaid on the page?

Many thanks.

#404709

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+00:00)

Those category links are added by WooCommerce, which generates the HTML and CSS.

You can override the styling using custom CSS added to your View, but I'd worry about that if and when you actually want to go ahead and include them on the page...