Skip Navigation

[Resolved] Widget Views Filter – Target Page: drop down does not work

This support ticket is created 8 years, 2 months ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Tagged: 

This topic contains 2 replies, has 2 voices.

Last updated by cathieH 8 years, 2 months ago.

Assigned support staff: Luo Yang.

Author
Posts
#229513
07-07-2014 22-08-57.jpg

Hello,

I'm using your Types and Views plugin on this Jobs Recruitment site and I've created a parametric search that works on the search page here: hidden link

I've then created a widget on the home page that displays only the form: hidden link

That widget is the WP Views Filter widget and it should normally have a working 'target page' drop down list. However the dropdown list isn't working. Yes I do have several sets of pages and created a dedicated search page as referenced above.

I cannot get the search form to forward the search to the appropriate search page.

What can I do to fix this issue?

I'm using:

Wordpress 3.9.1
Types: 1.5.7
Views: 1.6.1

Thank you.
Cathie.

#229583

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Hi Cathie,

Please try this:
1) deactivate other plugins and switch to wordpress default theme,
2) enable wordpress debug mode, repeat the actions you mentioned above, and post the debug logs here.
https://toolset.com/documentation/user-guides/debugging-types-and-views/
Also check if there is any javascript errors

and you can add a text widget, put Views filter form shortcode into it, like this:
[wpv-form-view name="my view name" target_id="123"]
123 is the target page ID

#229678

I haven't tried the debug but did use your text widget example and it works a dream.
Thank you.
Cathie.