[Resolved] When sorting is changed, formatting is lost

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by chrisD-14 9 months, 3 weeks ago.

Assigned support staff: Waqar.

Author
Posts
#1263153

Issue 1
I have a number of product listing pages set up using views. The site needs to have the ability to sort by price in ascending and descending order. I want the products to reload when a change is made to the drop down (that specifies Lowest to Highest and vice versa).

when I make a change, the products reload, but the template gets all screwed up.

Issue 2
If i want to add fields to custom post types, I get an error that says my site is experiencing technical difficulties, and that the site admin will receive an email with instructions. No such email ever arrived, either in inbox or junk mail.

#1264143

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Chris,

Thank you for contacting us and I'd be happy to assist.

Issue 1:

I've performed some tests on my website, with a similar view and template settings, but couldn't reproduce this issue.

It seems that the way some custom CSS code has been included in your website's view, it doesn't get included when the results update through AJAX (without the page reload).

For further troubleshooting, would it be possible for you to share a clone/duplicator package of your website?

Here is a guide on how to share the website's clone/duplicator package:
https://toolset.com/faq/provide-supporters-copy-site/

Note: your next reply will be private so that you can share it securely.

Issue 2:

I noticed that the email "steve.law@agency850.com" is set as the website's admin "Email Address" at WP Admin -> Settings -> General.

Can you please make sure that no email is received on this email address as well?
( please make sure to check the spam folder, as well )

In case you still are not receiving WordPress error recovery emails, please turn on WordPress debugging mode and check if any errors or warnings are shown on the screen or in the server's error log:
https://wordpress.org/support/article/debugging-in-wordpress/

regards,
Waqar

#1264345
#1265559

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Chris,

Thank you for sharing the duplicator package.

I was able to successfully deploy your website's clone on my own server and can see the issue with formatting, however, it is still not reproducible on a new/clean install.

A quick workaround is to make the sorting feature not use the AJAX, by selecting the "Full page refresh when visitors click on the search button" option, in the "Custom Search Settings" and also include the "Submit button" shortcode.
( ref: https://toolset.com/documentation/user-guides/views-shortcodes/#vf-153263 )


[wpv-filter-submit output="bootstrap"]

( screenshot: hidden link )

I'll need to perform some more tests to confirm why this is only happening on your website's install and will share my findings, as soon as this testing has completed.

regards,
Waqar

#1266609

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Chris,

Just wanted to update that this report has been escalated to the concerned team.

I'll update you as soon as, I'll hear back from them.

Thank you for your patience.

regards,
Waqar

#1266979

We were able to find a workaround for the problem. Thanks for the help.