Skip Navigation

[Resolved] when activated, no search results

This support ticket is created 6 years, 8 months ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Hong_Kong (GMT+08:00)


This topic contains 2 replies, has 2 voices.

Last updated by johnh-18 6 years, 8 months ago.

Assisted by: Luo Yang.


I am trying to: there is a clash between the types plugin and my search results - when I activate the types plugin, I do not get any search results. However, if I create a page in a custom post type, that page appears in the search result
I visited this URL:
This is a staging site that I am working on - hidden link
I expected to see:
This is the live site where I do not have types installed
hidden link

The site is a genesis site.

Also, I am not sure if it is needed but the site key from the registration of hidden link is rejected

Look forward to hearing from you.
Best regards/john

Instead, I got:


Hi John,

Since you are using some custom plugins and a custom theme.
We need to know if there is any compatibility problem in your website,
Please check this first:
1) deactivate other plugins and switch to wordpress default theme, and test again
2) Enable PHP debug mode, copy and paste the debug logs here
PHP Debugging
In case you think that Types or Views are doing something wrong (what we call a bug), you should enable PHP error logging. Again, edit your wp-config.php file and add the following:

ini_set('error_reporting', E_ALL);
ini_set('error_log', dirname(__FILE__) . '/error_log.txt');
This will produce a file called ‘error_log.txt’ in your WordPress root directory. Make sure that the web server can create and write this file. If it cannot, use an FTP program to create the file and make it writable to Apache (normally, user www-data).


Hi Luo,
Thank you for your message and I should have thought about deactivating all other plugins. The culprit seems to be another plugin that I do not need in the new structure so believe that all is sorted.
Best regards/john

This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.