Skip Navigation

[Closed] Views: View breaks next have_posts() loop?

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by Caridad 7 years, 9 months ago.

Assigned support staff: Caridad.

Author
Posts
#28587

I have added a view to a page. I have tried both the <?php echo(render_view($args)); ?> and widget methods. The view shows correctly on the page, however directly under the view is a wp-query to show recent blog posts. When the View is active the recents posts breaks and instead of showing recent posts it shows all posts. When I hide the view the recent posts works.

I have even gona s far as to add wp_reset_postdata(); and wp_reset_query(); under the view, but this does not work either. Can you help point me in a direction that may help me solve this issue?

Thank you,
Michael

#28615

Dear Sammut,

To debug this properly I will need a dump of your database and a copy of your theme files. Can you send it to my email address?

Regards,
Caridad

#30660

Dear Sammut,

It seems to be working correctly on my setup. Could you try updating your plugins? We released an update today.

Other than that, I didnt have as many plugins enabled as you. Try disabling some until you find what causes the problems.

Please let me know if there is anything else that I can assist you with.

Regards,
Caridad

The topic ‘[Closed] Views: View breaks next have_posts() loop?’ is closed to new replies.