[Closed] Views filter act strange in secondary language

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by Noman 1 year, 9 months ago.

Assigned support staff: Noman.

Author
Posts
#614502

hidden link

This site is made with Toolset & WPML.
The filter is working but not with 2nd language (in this case "English" ).

Please use chrome to see this site. And use one of these filters.
The site will be shown in Japanese instead of English.
FThe filter is working so I don't know why?

#614646

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Junichiro,

Thank you for contacting Toolset support. Please try to check it by deactivating all third-party plugins (except Toolset and WPML) and switching back to the Default Theme (e.g. Twenty Sixteen theme) to see for any possible conflicts with any of the plugins or themes?

If still issue persists, please provide temporary access WP-Admin Login and FTP login info to your site. Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

✙ Please add the Link to the [View] Edit Screen.

Thank you

#615168

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hello Junichiro,

I have re-saved the default language and it resolved the issue. Please clear browser cache and check the page again here:
hidden link

I have recorded a video to confirm:
hidden link

Thank you

#615171

Thank you for your support.
Could you try without login?

#615186

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Okay, now the issue is when we logged out?

Can you please try to check it by deactivating all third-party plugins (except Toolset and WPML) and switching back to the Default Theme (e.g. Twenty Sixteen theme) to see for any possible conflicts with any of the plugins or themes?

Or allow me to check theme/plugin conflict?

#615191

The deactivating test has already done when you reply to me on February 9. Still, have a problem with it.

#615525

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

I have enabled: WPML > Language filtering for AJAX operations. Now its working as expected in both languages.

Thank you

#615551

Thank you very much !!!

It looks like you've changed WPML url setting from parameter"?lang=en" to directory "/en/".
Is it possible to keep using parameter URL ?

It seems working fine except "Reload".

hidden link
Visit this English page and play with filter, then press Reload.
-> I move to Japanese page.

How can I keep in same language ?

#615584

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Is it possible to keep using parameter URL ?
>> Yes, you can.

Visit this English page and play with filter, then press Reload.
-> I move to Japanese page.

>> I am not able to reproduce this issue, can you please record a short video of the issue?

#615589

Here is movie file.
hidden link

You will see
"?lang=en" is removed when I change parameter URL.

Thank you for your great support !!!

#615714

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Okay, so now the issue is regarding URL parameter, I suggest to bring this up in the WPML forum as well, as this seems related to WPML in your case.

Thank you

The topic ‘[Closed] Views filter act strange in secondary language’ is closed to new replies.