Skip Navigation

[Resolved] Views admin UI jQuery error when trying to add a custom field

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 6 replies, has 3 voices.

Last updated by Kristin 7 years ago.

Author
Posts
#267184
Screen Shot 2014-12-03 at 2.15.20 PM.png
Screen Shot 2014-12-03 at 2.11.21 PM.png

Hi, I'm trying to add a custom filed into Views but nothing happens. I can see there are some jQuery errors...

/dev/wp-admin/load-scripts.php?c=0&load%5B%5D=jquery-core,jquery-migrate,jq…d,jquery-ui-sortable,mediaelement,wp-mediaelement,media-views&ver=4.0.1:50 Uncaught TypeError: Cannot read property 'isArray' of undefined
/dev/wp-includes/js/tinymce/plugins/compat3x/plugin.min.js?ver=4104-20140822:1 Deprecated TinyMCE API call: <target>.onNodeChange.add(..)
/dev/wp-admin/load-scripts.php?c=0&load%5B%5D=wp-pointer,heartbeat,wp-auth-…,admin-comments,postbox,dashboard,media-upload,wplink,editor&ver=4.0.1:520 Uncaught TypeError: Cannot read property 'each' of undefined

I guess this is probably a plugin conflict? I'll try and install the site locally and disable the plugins to see...

#267190

Hold your horses everyone, don't worry I've figured it out. It turned out to be the 'Stream' plugin now has a conflict with Types - or vice versa.

hidden link

If anyone at Toolset has time to look into it that would be great 😉 otherwise I'll get the Stream chap onto it

#314997

I'm having this same issue - was there a resolution other than disabling Stream?

#315010

Hi Ian, no, sorry I'm not aware of any other way around it yet.

Although I'm considering using 'VersionPress' instead for some clients as it's seems like the a logical progression: hidden link

#319403

Can confirm that I'm experiencing the same issue as well. Only appeared recently as far as I know, but a major issue. Had to disable stream, but would like to know if Views is the culprit.

#319423

Stream and Views definitely don't play nicely together at the moment. Maybe post a new support thread and link it back to this one because Toolset support will probably never find this '[Resolved]' post

#319433

Thanks - already created a new thread.