[Resolved] View showing different content in archive listing

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Tagged: 

This topic contains 3 replies, has 2 voices.

Last updated by Shane 8 months, 1 week ago.

Assigned support staff: Shane.

Author
Posts
#1374609

I have created premium content for registered users like this:

hidden link

I created View for the wordpress archive listing using a content template. Here is how one looks like:

hidden link

I expected to see:

[wpv-post-featured-image]
[wpv-post-link]
[wpv-post-date]
[wpv-post-excerpt]...like I have set in my view and content template

Instead, I got:

I see the a login form / replaced content!

hidden link

How can I show this premium content as normal post in the archive view?

Best regards,

#1374643

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Suzan,

Thank you for getting in touch.

I'm not quite sure of the issue.

Is it that you want your non-premium users to be able to see the premium content when its listed on the archive page?

Please clarify for me.

Thanks,
Shane

#1374795

Hi Shane,

No

I want the premium content to appear just like all other posts in the archive lists with title, thumb, date. Now the view is displaying the login form instead. I don't want View to display the login form

Thanks

#1375513

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Suzan,

Given that you've restricted the Post Type to only users who are premium and logged in then the archive will require that you have a premium account to view ass well.

Unfortunately this is how it works and there isn't a workaround unless you're not restricting the post type but rather the individual post or even the contents of the posts using a content template.

This way users can still navigate to the post but only the users who have the permissions can view the actual content of the post.

Please let me know if this helps.
Thanks,
Shane